
Store Visualizer 14
- User guide -





Welcome
This user guide will introduce you to Store Visualizer 14. It provides a step-by-step approach to the most commonly 
used features and will allow you to quickly familiarize yourself with the software. 

We hope you enjoy using Store Visualizer !
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You may access help and technical support resources at any time from within Store Visualizer. 
Press the “Help” icon located on the left hand side of the bottom toolbar, as shown on the image below. 

Product manual
Selecting the “Open product manual” option will open the Store Visualizer user guide, which you are currently reading. You may also 
press F1 at any time to access this manual.

Store Visualizer quickstart guide
An online quickstart guide is available as a quick and easy step-by-step introduction into Store Visualizer. You can open the quickstart 
guide by selecting the second option in the “Help” menu or by clicking the following link: 
Quickstart guide

Technical support
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A.  Navigation
B.  Object control
C.  Environment
D.  Physics

Toolbar panel

Chapter 1 : Interface

The Store Visualizer user interface is divided into two distinct parts: a horizontal toolbar and information panel at the bottom and a vertical sidebar 
on the right hand side. The panel accesses navigation and interaction toolbars, while the sidebar contains control, scene and project related features. 
The 3D visualization is displayed on the large gray area, the render area.

Sidebar

The sidebar contains three 
feature categories which 
can be accessed by clicking 
on the respective tab:
  - System sidebar tab
  - Tools sidebar tab
  - Scene sidebar tab

Figure 1-02

Figure 1-01

A B C D

Right click anywhere on the gray empty area (the 3D render area). 
The main contextual menu will appear.

Contextual menu
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This toolbar controls how the user navigates and moves through the environment or 3D world (see chapter 2 and 3).

This toolbar contains lighting and environment related functions and parameters (see chapter 13).

The object toolbar allows the placement and interactive modification of objects within a 3D environment (see chapter 7).

A. Navigation

B. Object placement

C. Environment

1.1  The toolbar and information panel

The “tool” panel, located at the bottom of the screen, is divided into four separate tool bars. They can be enabled by clicking on their respective toolbar 
icon on the left hand side of the tool panel (Fig. 1-01).

The entire interface (Toolbar and sidebar) can be made invisible simultaneously by clicking on one of the “Hide interface” icons located to 
the left and right extremities of the toolbar. To make the interface reappear, move the mouse pointer into the lower left or right corner of the 
screen and click the left mouse button. You may also press the “i” key to toggle interface visibility. 

The Physics toolbar is used to control and configure the physical simulation (see chapter 14).

D. Physics
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Individual rollouts are detachable and dockable, so to make commonly used features easier for access. Click on the “small arrow” icon on the right 
side of a rollout header to detach it (Fig. 1-03). Most sidebar rollouts are resizable in their detached state, allowing a more efficient usage. They can 
be docked again to the sidebar by simply closing them (Fig. 1-04).

1.2  The sidebar

Figure 1-03

The sidebar is visible by default when running Store Visualizer for the first time. Press the “b” key to toggle the sidebar visibility. This will allow for a 
larger view onto the 3D area.

The sidebar is the vertical area located on the right hand side of the screen. It is separated into three sections giving access to distinct feature 
categories: System, tools and scene (Fig. 1-02). A section can be enabled by clicking on its respective sidebar tab. 

Each section contains a number of rollouts which can be open or closed. Click on a rollout header to open it and a second time to close it again.

Figure 1-04
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The time to load a project will vary according to its size and complexity. The larger the project, the longer the loading will take.

1.4  Opening an existing project

Using the contextual menu:

Or, using the system sidebar:

• Right click on the Store Visualizer render area to open the main contextual menu.

• Select: File > Open.

• The “Open file” dialog window will appear.

• In the system sidebar, open the “File” panel, and select: Project > Open.

• The “Open file” dialog window will appear. Browse through your computers file hierarchy to find the project you would like to open.

• In order to enter a folder, just double click on it.

• Double click on a project file or select it and click on Open.

• The project will load, and a loading bar will show the progress of the operation.

1.3  Creating a new project

Store Visualizer supports two distinct project types : spherical photographic environments and virtual 3D environments. Each project type offers 
a distinct set of features when creating it and interacting with it. Please refer to chapter 2 and chapter 3 for a detailed explanation of spherical and 
virtual 3D environments respectively.
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1.6  Saving the project

Using the contextual menu:

Or, using the system sidebar:

A small disk icon appears on the bottom information panel if the current project was modified. Clicking it will save all changes to the current 
project file, and is identical to the Save operation outlined above.

• Right click on the Store Visualizer render area to open the main contextual menu.

• Select: File > Save or File > Save as.

• Save will write any modifications to the currently opened project file.

• Save as lets you save the current project under a new file name. The previous project file will not be modified.

• In the system sidebar, open the File panel, and select: Project > Save or Project > Save as.

• Save will write any modifications to the currently opened project file.

• Save as lets you save the current project under a new file name. The previous project file will not be modified.

1.5  Closing a project

Using the contextual menu:

Or, using the system sidebar:

When closing a project with unsaved changes, Store Visualizer will ask whether the modified project should be saved, the modifications 
discarded, or if you prefer to cancel the operation.

• Right click on the Store Visualizer render area, and select: File > Close.

• In the system sidebar, open the “File” panel, and select: Project > Close.
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1.7  Quitting Store Visualizer

Using the contextual menu:

Or, using the system sidebar:

When attempting to quit with unsaved changes, Store Visualizer will ask whether the modified project should be saved, or the modifications 
discarded.

• Right click on the Store Visualizer render area to open the main “contextual menu”.

• Select: File > Quit.

• In the system sidebar, open the File panel, and select: Project > Quit

18												                       Store Visualizer 14



A project based on a spherical photographic environment allows you to place your 3D models into photographically acquired shelving from an actual 
existing store. Your packaging models and products can be seamlessly integrated with existing photographic products already on shelf.

Store Visualizer comes with 5 sample spherical environments. Additional environments can be created according to your specifications, in a location 
of your choice. Please contact your sales representative for more information about this service.

2.1  Introduction

Chapter 2 : Spherical photographic environments
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A new project can be created by one of two different ways:

Or alternatively:

• Right click anywhere on the gray empty area (the 3D render area). The main 
contextual menu will appear.

•  Select File > New.

•  The “Create a new project” dialog window will appear (Fig. 2-03).

•  In the System sidebar tab, open the “File” panel and select Project > New. 

•  The “Create a new project” dialog window will appear (Fig. 2-03).

Figure 2-01

Figure 2-02

2.2  Creating a new spherical project from a template
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Figure 2-03

A path directory can be configured in the preferences. Preferences > Path & directories > File paths 
> Templates.

• Click on the “spherical” tab. A list of available spherical templates will appear. 

• Select a template from the list and press OK to open it.

• An empty project will be created from the template. Modifying this new project will not alter the template it was 
created from.
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o  Moving:
  Click and hold the left mouse button or press the arrow up key to move FORWARDS
  Click and hold the left mouse button or press the arrow down key to move BACKWARDS

o  Turning and looking around:
  Move your mouse upwards in order to look up (see note below)
  Move your mouse downwards in order to look down (see note below)
  Move your mouse to the left in order to turn to the left
  Move your mouse to the right in order to turn to the right

Figure 2-04

You can modify the speed (chapter 2.4) and sensitivity of your movements (chapter 4). You may also flip the up and downwards directions 
of your mouse (Select: File > Project > Preferences > System settings > Interactivity > Navigation settings > Invert freelook mode).

• Select the navigation toolbar by clicking on the “Navigation” icon (Fig. 1-01) located on the bottom panel bar.
• The navigation toolbar appears (Fig. 2-04), and is now active.

2.3  Navigating in a spherical photographic environment

• Click on either the “Free look” icon, the Middle mouse button (often the scrollwheel !), or the Spacebar to enable freelook mode. 
The mouse cursor and the toolbar will disappear, and the freelook mode is activated.

• By using your mouse or keyboard, you may now navigate within the photographic environment:

o  Exiting the “free look” mode:
  Click on the middle mouse button (or the spacebar) a second time, and the mouse pointer will reappear.
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2.4  Navigation speed

You may change the speed of your movements in the spherical environment using the speed selector button: 

• The speed selector is located on the right hand side of the navigation toolbar.

• Click on the “Select navigation speed” to open the “speed preset list“ (Fig. 2-05).

• Select an appropriate speed level.

Figure 2-05

By default, the speed list contains 5 generic presets.
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A virtual 3D environment gives you complete control over the design and the layout of your 3D virtual retail space. Using the store and shelf editing 
features of Store Visualizer, you can easily add shelving, create aisles, fill them with products and customize the look of your store in real time. 

A project based on a virtual 3D environment allows full freedom of movement and interaction of both camera and 3D models within the simulated 
area.

3.1  Introduction

Chapter 3 : Virtual 3D environments
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A new project can be created by one of two different ways:

Or alternatively:

• Right click anywhere on the gray empty area (the 3D render area). The main 
contextual menu will appear.

•  Select File > New.

•  The “Create a new project” dialog window will appear (Fig. 3-03).

•  In the System sidebar tab, open the “File” panel and select Project > New. 

•  The “Create a new project” dialog window will appear (Fig. 3-03).

Figure 3-01

Figure 3-02

3.2  Creating a new virtual 3D project from a template
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Figure 3-03

A path directory can be configured in the preferences. Preferences > Path & directories > File paths 
> Templates.

• Click on the Virtual 3D tab. A list of available virtual templates will appear.

• Either select an existing template from the list or click the “Create new” button to add a new template (see chapter 
3.3).

• An empty project will be created from the template. Modifying this new project will not alter the template it was 
created from.
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3.3  Create a new virtual store template

Figure 3-04

The dimensions of the created empty store are shown in the area below the list.

• Click the “create new” button and select the “Virtual 3D store” entry in order to launch the store creation wizard.

• Select the type of ceiling and light configuration from the “Structure” list (Fig. 3-05).

• Select the flooring you would like to use in the “Floor” list (Fig. 3-06).

• Click on OK to generate the store using the selected elements. The “Save new store project” dialog will appear. 
Enter the name of the new store template and press Save. An empty project will automatically be created and the 
new template will be added to the list of available templates.

The reflectivity and the glossiness of the floor can be adjusted using the entry fields below the list.

Figure 3-05 Figure 3-06

The store generation wizard will create two files for every new store template: a 3dw file and a corresponding vtpr file. The 3dw file is 
required by every project that is derived from the template. If you move a project file from one computer to another, you will also need to 
copy the corresponding 3dw file. Failure to do so will result in an error when opening the project !
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o  Moving:
  Click and hold the left mouse button or press the arrow up key to move FORWARDS
  Click and hold the right mouse button or press the arrow down key to move BACKWARDS
  Press the right arrow key to move sideways to the RIGHT
  Press the left arrow key to move sideways to the LEFT

o  Turning and looking around:
  Move your mouse upwards in order to look up (see note below)
  Move your mouse downwards in order to look down (see note below)
  Move your mouse to the left in order to turn to the left 
  Move your mouse to the right in order to turn to the right

o  Exiting the free look mode:
  Click on the Middle mouse button (or the Spacebar) a second time, and the
mouse pointer will reappear.

• Select the navigation toolbar by clicking on the “Navigation” icon (Fig. 1-01) located on the bottom panel bar.
• The navigation toolbar appears, and is now active.

Several different ways to navigate through a realtime 3D environment exist:

3.4.1  The “FREE LOOK” mode

You can modify the speed (chapter 3.5) and sensitivity of your movements (chapter 4). You may also flip the up and downwards directions 
of your mouse (Select: File > Project > Preferences > System settings > Interactivity > Navigation settings > Invert vertical mouse).

• Click on either the “Free look” icon, the Middle mouse button (often the scrollwheel !), or the Spacebar to enable free look mode. 
The mouse cursor and the toolbar will disappear, and the free look mode is activated.

• By using the mouse or keyboard, you can freely navigate through the 3D environment:

3.4  Navigating through a full 3D environment
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3.4.3  Orbiting around a target

You may move in circles around a certain point or object using the “Target orbit mode” :

You may use the orbit mode combined with the free look mode. This will allow you to control the distance to the orbit location using the left 
and right mouse buttons (see chapter 3.4.1 for more information about the freelook mode).

• Click on the “Orbit” button. Store Visualizer will query you for an orbit center position.

• Point the cursor onto the object or location you would like to orbit around, and left click your mouse to confirm.

• To circle around the selected location, click and hold the left mouse button while moving the mouse. The camera will follow your 
mouse movements while always keeping focused on the orbit location.

• To exit the orbit mode, just click the orbit icon again.

3.4.2  The “WALKTHROUGH” mode

The walkthrough mode is more limited in movement freedom than the freelook mode, but keeps the mouse cursor visible instead. Please 
refer to chapter 3.4.1 for more information.

o  Moving:
  Click and hold the left mouse button in order to move FORWARDS.
  While moving, point the mouse cursor into the direction you would like to walk.

Walkthrough mode is disabled by default. You can enable it in the navigation options (see chapter 4).

Without using the free look mode, you may still navigate through your project using the “Walkthrough” mode. The mouse pointer will stay visible 
and allow normal access to the application in this mode.

Store Visualizer 14	 29



3.4.4  Set camera height preset

The current height of the camera (as measured from the ground floor) is shown on the navigation toolbar. A selection of standard height presets is 
available by clicking on the “Height” selector.

• Click on the “Height” selector button located on the navigation toolbar. A list of height presets will 
appear

• Select a height entry. The camera will automatically adjust to the new view height.

While navigating in freelook mode, you can interactively adjust the camera height by using the Page Up / Page Down keys:

You can numerically enter a precise height in the navigation options (see chapter 4).

• Press Page Up to increase the camera height (moving up).

• Press Page Down to lower the camera height (moving down).

3.4.5  Toggle layout view

The “layout view” mode will show your store from a birds eye perspective while temporarily removing the ceiling. This mode offers a general view of 
the store floor plan and is well suited for editing the larger scale layout of your project. You will find more information about the layout view mode in 
chapter 9.8.

• Clicking on the “Toggle layout view” icon toggles the mode on and off.

• Click on the “Lock height when moving” entry in the height preset list to toggle height locking on and off. 
• When unlocked, the camera will be floating and gravity-less. When locked, a human observer with a fixed view height will be simulated.

By default Store Visualizer simulates a walking person and the selected view height stays constant while you navigate through the environment. 
Certain situations may require more freedom of movement, such as store construction. For these cases, the height can be unlocked.
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3.4.6  Align camera to nearest axis

If you have lost orientation during navigation, clicking on the “align camera to nearest axis” feature will place your view at a standard orientation.

• Open the “More actions” menu located on the right hand side of the navigation toolbar.

• Select “Align camera to nearest axis”. 

• The camera view direction will automatically align itself onto the nearest X, Y or Z axis.

3.5  Navigation speed

You may change the speed of your movements through the 3D environment using the speed selector button: 

• The speed selector is located on the right hand side of the navigation toolbar.

• Click on the Select navigation speed to open the “speed preset list“ (Fig. 3-07).

• Select an appropriate speed level.

Figure 3-07

The speed selector contains five presets, from very slow to very fast. The normal preset represents the 
average walking speed of an adult.
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o  Enable walkthrough: When checked, the walkthrough navigation mode is enabled (chapter 3.4.2).
o  Lock camera position:

  When selected, the camera position is locked. The orientation can still change.
  Moving the camera will change the field of view rather than move the position.
  You may still adjust the position manually by editing the position fields below.
  This lock is important in spherical photographic environments (see chapter 2).

o  Enable collision detection:
  Collision is applied to all geometry.
  Collision is applied to the ground only.

o  Height lock behavior:
  Lock affects walkthrough mode only.
  Lock affects freelook mode only.
  Lock affects both modes.

o  Sensitivity:
  Changes the sensitivity of mouse movements in navigation. Moving the slider to the left reduces

sensitivity, moving it to the right makes the navigation more sensitive.

o  Camera metrics:
  Position: Manual entry of the current camera position on the X, Y and Z axes (project scale).
  Rotation: Manual entry of the current camera rotation around the X, Y and Z axes.

o  Camera view locking:
  Clicking the view lock icons will prevent the camera view from changing on the respective axes.
    Clicking the icons again will release the lock. 

Chapter 4 : Navigation options
Numerous options will affect navigation behavior:

For more information about the height 
lock function, see chapter 3.4.4 

• Make sure the navigation toolbar is active (see chapter 3.4).
• On the sidebar, select the Tools tab, and open the “Navigation options” panel. Fig. 4-01 will appear.

Figure 4-01

X
Y

Z

Axes

Available when the Physics system is 
running, see chapter 14. 
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5.3  Next and previous camera

5.1  Create new camera

New camera is the default name.

• Click on the “left arrow” to switch to the previous camera.
• Click on the “right arrow” to switch to the next camera.

• Click on the “Add a new camera” icon.
• The “Camera properties” dialog will open (Fig. 5-02). Enter the name of the new camera.

5.2  Camera list

The list of currently stored camera views can be easily accessed from the toolbar by using the camera selector. When 
choosing one of the available cameras, the 3D view will automatically switch to the location and view direction stored 
with the camera entry that was selected.

Chapter 5 : Using cameras

Figure 5-01

• Select the navigation toolbar by clicking on the “Navigation” icon (Fig. 1-01) located on the bottom panel bar.
• The navigation toolbar appears (Fig. 5-01), and is now active.

Select “Edit camera settings” at the bottom of the list to open the camera properties dialog.

The Ctrl-Left and Ctrl-Right keyboard shortcuts can be used to easily cycle through all available camera presets. 
These shortcuts are also available in freelook mode.
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5.4  Edit camera settings

Figure 5-02

o  Add new entry: Create a new camera preset at the current location.

o  Edit camera position allows the modification of an existing preset. Click on the “Edit camera 
position” button to enable modification mode. Use the usual navigation functions to move your 
camera to the new position. Click the “Edit camera position” button again to store the new 
position and view direction for the selected preset.

o  Remove entry: Remove the selected camera preset from the list.

o  Move entry up/down: Use these buttons to reorder your camera presets within the list.

The “Camera settings” dialog can be opened in two ways:

• Select the navigation toolbar by clicking on the “Navigation” icon (Fig. 1-01) located on the bottom panel bar.
• Open the camera presets and select “Edit camera settings” at the bottom of the list (see chapter 5.2).

• Select the navigation toolbar by clicking on the “Navigation” icon (Fig. 1-01) located on the bottom panel bar.
• Open “More actions” on the right hand side of the toolbar and select “Edit camera settings”.
• A window with all stored cameras will appear (Fig. 5-02).

Or :
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5.6  Film and lens settings

o  The Lens section defines how the camera optics will see the 3D scene.
             Field of View: Indicates the view angle of the camera lens in degrees. It will be interpreted as 	
               either horizontal, vertical or diagonal opening angle depending on the angle direction settings.   
             Focal lengh: Defines the focal lengh of the camera optics in mm. Several presets are available.

o  The Film format section describes the size of the virtual camera film: 
             Image size: Dimensions and ratio of the virtual film image. 
             Image presets: Several commonly used film size presets are provided.

Figure 5-04

5.5  Camera path

• Open the “camera settings” dialog (see chapter 5.4).
• Click the “movement speed” button and select a speed.
• Camera presets (see chapter 5) will now use the selected speed for the movement along their trajectories.

o  Instanly: The camera jumps to the selected preset instantly, no path is generated.
o  Fast: The movement speed along the camera path is high.
o  Medium: The movement speed along the camera path is average (this is the default).
o  Slow: The movement speed along the camera path is low.

When you select a camera preset, Store Visualizer will create a trajectory along which the camera will move starting from your current position to the 
selected destination. Store Visualizer will automatically handle acceleration, deceleration and the rotation angle of the camera along the path, so to 
make the movement smooth and natural.

Use the “camera path” settings to change the speed of movement along the trajectory.

Figure 5-03

A camera path does not handle collision situations with objects in the environment, even if collisions are 
enabled. When creating camera paths through your store, you should position your presets such that 
no large objects (for example shelving) is blocking the trajectory of movement when switching from one 
preset to the next. Adding a transitional preset between start and end points can help avoiding these 
situations. You can also modify the position of existing presets using the “edit” feature in the camera 
preset dialog (see chapter 5.4).

• Select the navigation toolbar by clicking on the “Navigation” icon (Fig. 1-01) located on the bottom panel bar.
• Open the “More actions” menu located on the right hand side of the navigation toolbar and select “Film and lens settings”.
• A window with all available camera lens and film settings will appear (Fig. 5-04).
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Figure 6-01

6.1  Current project
You can access and modify the currently loaded project parameters at any time by using the “Current project” panel in the System sidebar tab: 

Figure 6-02

Figure 6-03

Current project > Advanced

Current project > Advanced > Project information > Project

Current project > Author

• Open the “Current project” sidebar panel.

• The Project name is displayed at the top.

• This field contains the “project description”, and can be directly edited.

• The “Advanced” dropdown allows access to project information, project scale and security settings.

• The “Author” button opens the project author and categorization window (Fig. 6-04). 

• Title: The current project name.
• Author: The author of the current project.
• Subject: The subject of the current project.
• Created: Date and time when the project was initially created.
• Modified: Date and time of the last modification.
• More information: Optional comments about the project.
• Category: The optional project category name.
• Keywords: The optional keywords associated with the project.
• Project files: The physical location of the project (vtpr) and scene (3dw) files.

Chapter 6 : Project settings
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Current project > Advanced > Units & Scales

Current project > Author

Figure 6-05

Figure 6-06

• Distance unit: Unit of measure used for distances and surfaces.
• Weight unit: Unit of measure used for weight.

• Author: The author of the current project.
• Subject: Optional project subject. 
• Category: Optional project category name (used for file search by Windows).
• Keywords: Optional project keywords (used for file search by Windows).

This dialog changes the general units used to measure distances, surface area and weight in the current 
project.
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Chapter 7 : Product manipulation mode

Model libraries

In the Tools sidebar, open the “Library” panel. 
This panel will give you access to your 3D models 
that can be placed into the environment. It also 
offers features to organize, import and manage 
your 3D models.

Model browser

Open the “Model browser” panel. This panel 
shows a graphical 3D representation of the models 
selected in the model library and allows the visual 
inspection of a model before placement.

• Select the object placement toolbar by clicking on the “Object control” icon (Fig. 7-01) located on the bottom panel bar.
• The object placement toolbar appears (Fig. 7-02), and is now active.

Figure 7-01

Store Visualizer exposes three construction modes: product manipulation, shelf creation and store design. Each mode targets a specific process 
in the work flow of creating the layout and shelving of a retail space and filling it up with products.

This chapter focuses on the “product manipulation mode”. This mode is used in both spherical and virtual 3D projects for manipulating and interacting 
with products. A product is defined as any 3D object that is not part of the shelving, store furniture or larger scale construction structure of the store.

Most object manipulation functions shown here (such as movement or creation) are also available in other construction modes. Chapter 9 describes all 
available construction modes used to build your store.

Figure 7-02
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7.1  Using model libraries

The “Project Library”, which is loaded by default into every project, is a special internal library. Its 
contents are stored directly into the project file, while external libraries are merely referenced to. You 
cannot close or specifically save the project library.

• Clicking on the “Library” button will reveal the “External library” management menu:

o  New: Create an empty external library.
o  Load: Load an external library and add it to the project.
o  Close: Close the selected external library.

o  Save: Quicksave the selected external library.
o  Save as: Save the selected library as an external library file.

o  Library settings: Open the external library settings dialog.

o  Show complexity: Shows a complexity gauge in front of every 3D model 
entry, representing the models’ geometrical complexity (see chapter 7.4).

• Copy: Copy the currently selected entry to the clipboard.
• Cut: Copy the currently selected entry to the clipboard, and remove it from the library.
• Paste: Insert the content of the model clipboard into the library.

• Create folder: Create and insert a new folder at the selected position into the library.

• Import model or resource: Insert an external 3D CAD model file into the library.
• Import image: Insert an external image file into the library.

• Delete: Delete the currently selected model from the library.

Figure 7-03

• Models: Show or hide all 3D models contained in the library (this should usually be switched on).
• Assemblies: Show or hide all assemblies contained in the library.

Depending on the installed plugin modules, more stream types may appear here.

Search entries: The search function filters the displayed entries in the library panel according to your 
search terms.
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7.2  Importing an external object
You may import an external 3D CAD object into a library, so to use it as a model within Store Visualizer:

Figure 7-04

• On the sidebar, select the Tools tab, and open the “Library” panel (see chapter 7.1).

• Select the library or folder you would like to add the object to. This can be the Project Library, an external library or any folder therein. You may 
also select an existing model. The new object will then be added to the same library as the selected model. 

• Click on the “Import” icon (Fig. 7-04) or press Ctrl+i.

Store Visualizer can import several standard CAD formats depending on the available import plugins.

• The “Import library model” dialog will open. Navigate through your file structure and select the 3D files you would like to import. Several files 
can be imported at once.

• Confirm your choice by clicking on Open. Cancel will abort the import operation.

• The “Import settings” dialog (Fig. 7-05) will appear. It allows you to change the way objects are imported, how lighting is calculated, and how 
textures are applied.
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• Options:
o Ignore root node: The positional and rotational component of the root transformation is ignored.
o Merge specular maps: If the imported model specifies a secondary specular map, the importer 

will merge it with the primary specular map. This significantly reduces memory consumption and 
improves rendering speed. On rare occasions it may generate slight visual artifacts.

o Modifiable materials: When clicked, all materials used by the imported model will be editable with 
the material editor. See chapter 12 for more information about materials.

• Two sided geometry:
o Never: Never use two sided geometry, even if the 3D file specifically requests it.
o Auto: Automatically decide whether to use two sided geometry or not, following the requests of 

the 3D file.
o Always: Always use two sided geometry, even if the 3D file doesn’t request it. Note that this option 

should only be used in specific cases, such as when dealing with defective 3D files, as it can 
significantly impact performance.

Figure 7-05

• Esko compatibility: Enable support for Esko specific data in Collada files. This will improve the visual 
quality for models exported from Esko software.

The two sided geometry mode can be independently set for opaque and transparent geometry. Two sided faces are generally not useful on opaque 
geometry, unless the 3D designer specifically required them in the design process. They can negatively impact performance, and should therefore 
be disabled. However, they can significantly improve visual quality on transparent materials, and should be enabled by request from the 3D file (Auto 
setting).

Most modern 3D CAD formats supply their own object scale, which Store Visualizer will use. Sometimes however, that scale may be incorrect. Older 
3D CAD formats may not supply a scale at all. In these cases, you can manually specify the object scale using the Override scale option. 

• The file format of the imported 3D model.
If multiple models with different file formats are imported simultaneously, then the import 
parameters (Fig. 7-05) can be individually adjusted for each format.

7.2.1  Model options
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Figure 7-06

Mapping coordinates control the way textures are applied onto the surface of a 3D object. Typically, these coordinates are added when a model is 
designed in a CAD application. Store Visualizer will automatically make use of these coordinates, if they are available.
Sometimes however, you may want to override the original mapping and replace it with your own. Some 3D file formats may not support mapping 
coordinates at all. You can use the mapping options to create and add new mapping coordinates to any imported model.

Checking the “generate custom UV mapping” box will enable mapping coordinate generation. This will override any existing coordinates on the 
imported object. If you would like to use the original mapping coordinates available with the 3D object, then leave this box unchecked.

Store Visualizer supports the following mapping modes:

• Box mapping: this will treat the model as a folded box. All six sides will be equally mapped and unfolded 
onto a common texture image.

• Flat mapping: this will map the model from two sides, which can be selected using the direction axis 
button. This mode is useful for adding two labels (typically front and back) to a relatively thin object, such 
as a flat bottle or a pouch.

• Cylindrical mapping: this mode should be used on cylindrical objects, such as bottles or cans. It will fit a 
circular label around the model and will optionally add top and bottom caps.

Replace material: when checked, the original materials will be removed from the object and replaced by a new material covering the entire model 
according to the selected mapping mode.

Generate caps: This will generate special mapping for the top and bottom caps in cylindrical mode.

Flat direction axis: In flat mapping mode, this drop down button selects the sides the two labels are added to.

Create a pattern: When this is checked, Store Visualizer will generate an image along with your model file, that will contain a pattern of the layout used 
with the selected mapping mode. You can use this pattern as a guide when drawing your own graphics onto the model. These can then be applied to 
the model using the material editor (see chapter 12).

The following options select the resolution of the pattern image file. Note that this resolution is just a base for the pattern image. You can freely modify 
the final image resolution from within your drawing application.

7.2.2  Mapping options
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This settings page controls how lighting and shadows are applied to the 3D object. You may also use this page to change the shader profile used for 
rendering your model. Typically that would be the Physical HDR 1.6 profile, unless you need backwards compatibility with legacy versions of Store 
Visualizer.

o  Vertex only: Use vertex lighting only (for geometrically complex objects).
o  Vertex and maps: Use both vertex and mapped lighting on the model (for regular objects).
o  Maps only: Use mapped lighting only (for large or geometrically simple objects).

Figure 7-07

• Shader profile: select the shader profile to use for the imported objects.

Ambient lighting simulates self shadowing of objects. Strongly concave objects (for example open 
boxes, trays, displays, etc) will project significant shadows onto themselves. If you look into an open 
box, for example, you will notice that the bottom is much darker that the top part. This is due to self 
shadowing or occlusion. This effect can be simulated with the ambient lighting feature.
Note that ambient lighting can take a considerable amount of time to calculate on complex objects. 
It might also consume a lot of memory at high resolution. Make sure to use ambient lighting only on 
objects where it will be visible. For example typical primary packs, bottles, closed boxes and containers 
will rarely take advantage of the effect, as they aren’t strongly concave. Open containers and shelving 
are the most appropriate type of objects for ambient lighting use.

Disabled Vertex and maps

Disabled Enabled

• Adjust shelf lighting: Option allowing more realistic shadows to be created for store furniture and on 
large 3D models with a complex and concave geometry (such as pallets, certain furniture that is open 
underneath, cars, etc.). 

• Ambient light map resolution and scale: Use this section to change the resolution and quality of the 
ambient lighting. Increasing the resolution will improve quality, but it will also increase the calculation time 
and memory consumption.

7.2.3  Settings
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• Texture resolution: The size selector defines the maximal resolution the object textures will be imported 
at. Larger textures will be automatically resized to the specified maximum size. By default texture size is 
not limited.

Shadow fields disabled Shadow fields enabled

• Shadow fields will make your objects project shadows onto the environment and onto other objects around them. This effect is very important 
for visual realism and should typically be enabled for all objects.

• Detail level controls the resolution of the shadow fields. Unless you are running Store Visualizer on a graphics card with limited memory, it is 
advised to keep this setting on “high”.

• Shadow quality controls the quality of the shadows. A higher quality will increase the preprocessing time, but it will not influence memory 
usage. You can use a lower detail value for quickly evaluating a product. When ready for presentation, reimport it with a higher detail setting.

44												                       Store Visualizer 14



The larger the imported 3D file, and the more complex the lighting options, the longer the import 
process will take.

• The imported object appears in the “Library” panel at the chosen place and is shown in the “Model 
browser” (see chapter 7.6).

Figure 7-09

• Once the object is imported without errors, press OK to add it to the model library. It can now be 
accessed as a standard Store Visualizer model.

• Pressing Cancel will discard the imported object without adding it to the library.

Once you have adjusted the import settings to your needs, you can start the actual import process:

• Click on the “Import” button.
• The status tab will automatically open and display the progress of the import process.

Figure 7-08

If a 3D file could not be imported, it will be marked as failed. Select the failed file in the list and click on the 
Import Log button to view more detailed information about the failure.

7.2.4  Status
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7.3  Importing an external image
Images may be directly imported as models. Store Visualizer will automatically map them onto an extruded 3D panel which can be placed into the 
3D environment like any other 3D model.

Figure 7-10

• On the sidebar, select the Tools tab, and open the “Library” panel (see chapter 7.1).

• Select the library or folder you would like to add the image to. This can be the Project Library, an external library or any folder therein. You may 
also select an existing model/image. The new image will then be added to the same library as the selected model/image. 

• Click on the “Import image” icon (Fig. 7-10).

• Confirm your choice by clicking on Open. Cancel will abort the import operation.

• The “import image file” dialog will appear (Fig. 7-11). It allows you to change the way images are imported, how they are extruded to 3D and 
how their 3D dimensions are obtained. It also specifies how shadows are generated.

• The “Import image file” dialog will open. Navigate through your file structure and select the image files you would like to import. Several files 
can be imported at once.
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o Thickness: Specifies the thickness of the resulting 3D image panel. This value can be zero, resulting 
in a panel without any thickness.

o Pixels per size unit: Determine dimensions automatically based on a fixed pixel size. When using 
this method, you specify how many image pixels fit into a given unit size. The image dimensions will 
then be automatically calculated based on this value. For example, if you specify 100 pixels per inch 
(100 DPI), the physical width of a 2000 pixel wide image will be 20 inches.

o Use embedded physical resolution if available: The PNG file format can optionally contain the 
actual physical size of the image. When checked, Store Visualizer will make use of this data if it is 
available.

o Use fixed dimensions: This method allows the manual specification of the precise physical image 
dimensions, regardless of the image resolution. If only one of width or height is specified, the respective 
other dimension will be automatically generated by using the image ratio. This is recommended, as it 
will avoid distortions. Alternatively, you may also specify both width and height manually. Please note 
that distortions will appear if you do not respect the image ratio in this case.

Figure 7-11

• The imported image appears in the “Library” panel at the chosen place and is shown in the “Model 
browser” (see chapter 7.6).

• The dimensions of the extruded image panel can be determined using the follow methods:

• The size settings define how image resolution in pixels relate to physical model dimensions (in distance 
units such as centimeters or inches) when the image is imported as a 3D model.

When an image with an alpha channel is imported, then a clipping mask will automatically 
be generated. The alpha channel will be used as an opacity mask. The material parameters 
and the use of the alpha channel can be controlled in the material editor (see chapter 
12).

7.3.1  Image options
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7.4  Organizing the model library

• You can change the name of a folder or model by typing it into the name area of the “library” panel.

• Click on a model to highlight it. This will select it for subsequent operation (eg. object creation) and make it 
appear in the “Model browser”. 

• Use the “Create folder” icon to create folders and subfolders. This feature will help you to organize large 
libraries.

• The Copy/Cut/Paste and Delete icons can be used to move, duplicate or delete the selected models and 
folders within their own or across several libraries. Press the Ctrl key while clicking onto an entry in order 
to select multiple models or folders simultaneously.

• Double click on a “+” sign to show the contents of the folder it precedes. Close the folder by double clicking 
the respective “-” sign.

• If the “show complexity” function is enabled (see chapter 7.1) a model complexity gauge will appear in 
front of every 3D model in the library. This gauge represents the geometrical complexity of the model. 
Complexity is a function of the amount of polygons in the model and also depends on the visual effects 
used (for example transparency). The higher the complexity of the model, the more the gauge will fill up 
and become red. Adding many complex models to your 3D environment may negatively impact rendering 
performance. 

It is very important to create well optimized 3D models in your CAD application ! Models should 
use the amount of polygons needed for the required quality, but no more. Adding more polygons 
will not improve visual quality, but can significantly degrade rendering performance. Many 3D 
models available on the Internet as part of generic 3D libraries are not well suited for realtime 
simulation.
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You can create customized external libraries that can be reused in different projects and shared between several users. These libraries support all 
features of the project library, including subfolders and hierarchies for easy organization and product classification in larger projects. External libraries 
promote the reuse of data and improve efficiency, since time consuming operations such as object imports become unnecessary.

7.5  Using external libraries

When you create a new library or modifiy an existing one (eg. copy, move or import models) an asterisk appears 
behind the library name. This is a reminder that you need to save the library in order to keep the changes. Store 
Visualizer will remind you again before closing the project. 

Figure 7-12

You may import an external 3D CAD object into your new library, so to use it as a model within Store Visualizer (see chapter 7.2):

Loading an external 3D library:

The file format extension of library files is l3dw.

• Select the library you would like to add the model to.
• On the sidebar, select the Tools tab and open the “library” panel (see chapter 7.1).
• Click on the “Import model or resource” icon. The “Import 3D file” dialog will open.

• On the sidebar, select the Tools tab and open the “library” panel (see chapter 7.1).
• Select Library > Load. The “Load model library” dialog will open.

Creating an empty external library:

• On the sidebar, select the Tools tab and open the “library” panel (see chapter 7.1).
• Select Library > New. A new empty external library will be created. You may now start adding models or assemblies 

to it (Fig. 7-12).
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The following fields can be used to describe the library. All of these fields are optional.
o  Author: The author of the new library.
o  Subject: Subject of the library.
o  Contents: Library content description. 
o  Comments: General description or comments related to the library.

The detailed texture settings for standard and high priority libraries can be configured in the Preferences > 3D settings > Textures.

This message appears when trying to close a library, and one or several models of that library are 
currently placed in the project environment. By clicking Yes Store Visualizer will remove all instances of 
these models from the project and close the library.  

This message appears when attempting to close a library with unsaved changes or a project containing 
such a library. Clicking Yes will save all modifications before proceeding. No will close the library without 
saving, all changes will be lost. Cancel will abort the operation.

Figure 7-13

o  In order to better control the performance and memory use of very large and complex 
3D products, priorities can be assigned to each imported library. Higher priority products, 
such as the ones from a customer during a presentation, can be displayed at the best 
possible quality level. Regular products, acting as fillers, can be optimized for speed, 
leading to better performance and lower memory consumption.

o  An important library is symbolized by a “green book” on the library icon. The priority 
status can be changed by using the check box on the library settings (Fig. 7-13). 

7.5.1  Saving a project with modified libraries

7.5.2  Settings for Library
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7.6  Using the model browser

While the mouse cursor hovers over the 3D view, you can press and hold the middle mouse 
button to move the object. The mouse wheel will zoom in and out.

Figure 7-14

• The “flag” icon will select all objects in the environment that are derived from the selected model.
• The “refresh” button will reload the model from disk. Use this feature if you modified the original 3D model 

or its texture images, and you would like the model in Store Visualizer to reflect these changes.
• The “show or edit anchor points” button open the anchor point dialog (chapter 8.2).
• The “show or edit anchor lines” button open the anchor and snap lines dialog (chapter 8.3)
• The “Level of details settings” button allows the adjustment of the LOD mode (see chapter 7.8)
• The “environment rotation” button control the orientation of the reflective environment within the model 

browser. When viewed in the model browser, a model will still reflect and be lit by the 3D environment it 
was positioned into. Click the earth icon to select the orientation angles to rotate this environment around 
the model. This will allow you to virtually turn around the model while it is shown in the model browser. Note 
that this setting will only affect models shown in the model browser, it has no effect on the models placed 
into an actual spherical or 3D environment !

• Use the rotation tool to rotate the model around two axes and inspect it from all sides.
• Use the movement tool to move the model within the display.
• Use the magnifying glass to zoom in and out of the model.
• The box tool will auto-recenter the model, so that it fits perfectly into the model browser view.
• Clicking on the option icon will open a list of parameters used to customize the view:

o  White pattern: use a light checker board background.
o  Dark pattern: use a dark checker board background.
o  Solid contour: use a solid color background.
o  Gradient: use a smooth two color gradient as background.

• View or assign model sides defines the front and top sides of the model (see chapter 7.7).
• Clicking show model dimensions will display the sizes of the imported model.

Once you selected a model in the library, it appears as an interactive 3D view in the “Model browser” panel. This 
view helps at inspecting the object before placing it into the environment. 

• This informational icon appears if the models contains transparency.
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• Select the side to assign: front or top side of the model. 

• Click on the model face that represents the selected side.

• Currently assigned sides are shown with arrows. The arrow is green for the side you are currently 
editing (front or top).

Many operations in Store Visualizer refer to a specific side of an object: front, bottom or left side for example. In order to function properly, Store 
Visualizer needs to know how your model is oriented with respect to its front and top sides. This information is usually not available in imported 3D 
files, so it has to be manually set.

To easily view and assign the front and top sides of a model, click on the “view or assign model sides” icon in the model browser.

7.7  Assign model sides

Often newly imported models have incorrectly assigned sides. It is important to correct 
these. Typically you will only assign the sides once, after importing a model. Your 
side assignment is stored with your library and can be modified at any time later on, if 
needed.
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7.8  LOD system

The level of detail (LOD) system dynamically simplifies objects that are far away from the current view, dramatically increasing rendering 
performance.

While this simplification is barely noticeable on most common objects, some specific 3D models (such as hollow objects like trays or containers) are 
less suited and may display visual artifacts when they are viewed from a distance. Store Visualizer uses an automatic heuristic to detect these models 
and will automatically disable LOD or select a more conservative LOD mode for them.

o Disable: Entirely disable LOD on the model. Only use this mode if the LOD system generates 
unacceptable visual artifacts on the model.

o Enable LOD in reflections: Objects are removed from reflections when they are far away, but no 
other LOD is used for them. Only use this mode if the LOD system generates unacceptable visual 
artifacts on the model.

o  Enable LOD everywhere: Enable the use of LOD on the model. This is the preferred LOD mode.

You can manually select the LOD mode for a model using the LOD settings icon. It is recommended to not 
modify the automatically selected mode unless you encounter heavy visual artifacts, as an incorrectly chosen 
mode may severely degrade rendering performance.
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• Once you have determined the position and orientation of the placement area, press the left mouse button to create a new instance 
of the object at the selected location.

• Once you have finished placing objects, press the “Create a new object” icon again in order to disable the placement mode.

7.9  Placing an object

You can place more than one object by repeating the last two steps as many times as you need. In order to place a different 
model, simply select the new one in the library panel.

o  A green arrow symbolizes the front face of the object. 

o  A yellow arrow symbolizes the back face of the object.

• Each object is derived from a library model. You need to select the model to be used in the library panel.

• On the object placement toolbar, enable the placement mode by clicking on the “Create a new object” icon.

• Move the mouse pointer to the surface you would like to place the object onto. If the placement is possible, a symbolic representation 
of the object will appear.

• You can use the mouse wheel to change the orientation of the object on the placement surface:

Creating an object will automatically switch to the appropriate construction mode. While the examples in this chapter focus on 
product manipulation mode, they will work the same way for models using other construction modes, such as shelves.
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7.11  Selecting an object

By default, selected objects are shown with an open yellow box around them. You can change the color of the selection box 
in the preferences. 

• On the object placement toolbar, enable selection mode by clicking on the “Select objects” icon.
• Position the mouse pointer over the object you want to select and press the left mouse button.

• Holding the Ctrl key while clicking the left mouse button will add the object to the current selection.

• Holding the Alt key while clicking the left mouse button will remove the object from the current selection.

• You can select or unselect several objects at once by using a selection area. Clicking the left mouse button, and dragging the mouse 
while holding the button down will create a selection rectangle. All objects within the area will be selected or unselected. The behavior 
of the selection area can be changed in the “Object control options” (see chapter 7.20).

• Clicking onto an empty area without an object under the mouse pointer will clear the current selection.

7.10  Selecting the construction modes

• Click on the construction mode selector and choose a construction mode to switch to.

Please find detailed information about construction modes in chapter 9.
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7.12  Moving a selection of objects

Usually, movement will be performed along two axes simultaneously. But it can be useful to restrain movement to a single axis, when higher 
positional precision is needed. At least one axis must be selected in order to allow movement.

7.13  Rotating a selection of objects

Rotation can only be performed around a single axis at a time.

• If you press the Ctrl key while still holding the left mouse button, the object will move along the direction perpendicular to the selected 
axes. For example, if the X and Y axes are selected (the default), then the object will move on a horizontal plane. If you press Ctrl, the 
direction will toggle to the Z axis, and you may move the object up and down.

• Enable movement mode by clicking on the “Move selection” icon.
• Movement is started by clicking onto a selected object with the left mouse button, and moving the mouse while holding the button.

• Click on the X, Y or Z axes in order to limit the movement to the requested directions.

• The movement axes are shown by the axis indicator on the placement toolbar:

• Enable rotation mode by clicking on the “Rotate selection” icon.
• Rotation is started by clicking onto a selected object with the left mouse button, and moving the mouse up and down while holding the 

button.

• The rotation axis is shown by the axis indicator on the placement toolbar:

• Click on one of the X, Y or Z axes in order to rotate around the requested axis.

• Pressing the Ctrl key while holding the left mouse button will increase the precision of the rotation.
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7.14  Scaling a selection of objects

Scaling will always change the size of the individually selected objects, and never the size of their parent models in the library.

7.15  Duplicating (cloning) a selection of objects
You can easily duplicate a single object or a set of objects in your project while preserving the original relative positions, orientations and scales:

The cloned objects are completely independend of the original objects used for the duplication.

• Select the object or the objects you would like to duplicate.

• Enable movement mode, as described in paragraph 7.12.

• Press and hold the Shift key, and click on a selected object with the left mouse button.

• While still holding both the Shift key and the mouse button, drag the mouse as if you where to normally move the selection as described 
in the paragraph 7.12.

• Release the Shift key, but keep holding the left mouse button. The cloned selection is now attached to your mouse pointer, and can 
be moved around freely until the mouse button is released.

• Enable scaling mode by clicking on the “Scale selection” icon.
• Scaling is started by clicking onto a selected object with the left mouse button, and moving the mouse up and down while holding the 

button. By default, scaling is isotropic, ie. it will preserve the axis size ratio of the object:

• If non-uniform scale is enabled (see chapter 7.20), you may select the scaling axes individually: 

• Pressing the Ctrl key while holding the left mouse button will increase the precision of the scaling.
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7.16  Auto select
When ”Auto select” is checked, then objects will automatically be selected while using the move, rotate or scale tools, without having to explicitly use 
the selection tool prior to an interaction. The Ctrl and Alt modifier keys for creating multiple selections are also available in this mode (see chapter 
7.11).

Unchecking “Auto select” will freeze the current selection while manipulating objects with the move, rotate or scale tools. 
The selection tool (see chapter 7.11) is used to explicitly change the selection.
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7.17  Pivots and coordinate systems

By default, the object is attached to the local bottom 
pivot, which is most appropriate for standard 
products on horizontal shelves. For products 
hanging from hooks (eg. blister packs), other 
application sides (eg. back) or anchor points should 
be used instead.

In object placement mode, the pivot is graphically represented as a yellow cross, and defines the point at which the object is attached to the 
placement surface. The arrow always shows the bottom - top direction within the local coordinate frame (pointing towards the top):

o  World: Use the global world coordinate system for all selected objects.
o  Local: Use the local coordinate system of each selected object.
o  Parent: Use the local coordinate system of the parent object (if any).
o  Pivot: Use the native pivot coordinate frame of the object (if one was defined).
o  Camera: Use the camera coordinate system for all selected objects.

The transform coordinate system selector defines the reference coordinate frame where all object operations take place in:

o  Center: Set the pivot to the geometrical center of the object or selection.

o  Local origin: Use the local origin of the object as the pivot.

o  Local sides (bottom, top, etc): Use the center of an object side as the pivot.

o  Anchor points: Use a user defined anchor point as the pivot (if one or more anchors were defined). See 
chapter 8.2.

The pivot defines the reference point around which objects are rotated or scaled, as well as the attach point when objects are created. It can be 
changed by clicking on the “Anchor” selector.
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Only the selected objects will be removed, their parent models in the library will not be affected. In order to remove a library model, please 
use the library control features described in chapter 7.1.

7.19  Removing a selection of objects

• Select the object or the objects you would like to remove from the project.

• Open the “More actions” menu located on the right hand side of the object toolbar.

• The “Delete” action will remove all selected objects.

7.18  Replace model

• “Replace model” replaces all objects in the current selection with the model currently selected in the library. You may also press the 
“e” key to replace the model.

The replace tool works on objects and groups created in “Product manipulation mode”, as well as on object arrays.

Alternatively you may simply press the Delete key to remove the currently selected objects. Cmd-Backspace can also be used on the Mac 
version of Store Visualizer.
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7.20  Object control options
• On the sidebar, select the Tools tab, and open the “Object control options” panel. Fig. 7-15 will appear. This option panel allows you to modify 

the way objects are placed, selected and manipulated.

o  The “Selection rectangle mode” defines the way the selection area operates:
  Inclusion mode (not pressed): only objects entirely included in the rectangle will be selected.
  Intersection mode (pressed): all objects partially touched by the rectangle will be selected.

o  The “Magnetic Snap” button opens the magnetic snap settings dialog (see chapter 8.5).

o  The “Surface tools” change the way surfaces are handled and how objects are positioned onto them:

  Automatic tangential align will automatically orient an object so that its pivot axis is always 
orthogonal to the surface. In other words, the object will always be aligned so that its base lies 
flat on the surface it was placed onto.

  Restrict surfaces: if enabled, then only surfaces of a specific orientation will be considered 	
valid for placement:

	   •  Top / Down facing: only surfaces facing up / downwards are considered.
	   •  Positive / Negative X axis: considers only surfaces facing +X / -X (usually left / right).
	   •  Positive / Negative Y axis: considers only surfaces facing +Y / -Y (usually front / back).
	   •  Custom surface: Only a custom, user defined surface is considered.
	   •  Lock to surface: A user defined surface is always used for all placement.

  Tolerance margin: applies the specified tolerance (in degrees) to the surface restrictions. This 
is useful when the surfaces are not entirely flat, yet a restriction is desired onto them.

  Transform constraints enable collision based limits when transforming an object.
  Allow non-uniform scale enables the ability to perform non-isotropic size modifications.

Figure 7-15
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7.21  Multiple object placement

The blue arrow at the edge of the surface cursor represents the FRONT of the filling volume. You may use the 
mouse scroll wheel to change the orientation while still selecting a surface.

The “Object array” feature can be used to quickly fill an area or volume with multiple objects arranged in specific patterns.

You can access and modify the properties of any selected array through the “Object array” dialog.

Use the mouse to select the surface you would like to base the new array on. Just as in object creation mode, the object 
control options (see chapter 7.20) will change the way surfaces are recognized by Store Visualizer.

In addition to selecting a base surface, the surface cursor also represents the starting point of the filling volume. This point is 
shown as a small blue cross at the center of the surface cursor. 

Release the left mouse button in order to finish the creation of the array. The blue surface positioning cursor will 
reappear and you can continue creating additional arrays. Click the “Create an object array” button again (or press 
‘f’) to leave the array creation mode.

• Make sure the object placement toolbar is currently enabled and select a model in the library. 
• Click on the “Create an object array” icon. The blue surface selection cursor (Fig. 7-16) will appear and the “object array settings” 

dialog will open (Fig. 7-18). 

• Once you have selected a surface and starting point, press and hold the left mouse button. When moving the 
mouse while holding the left button, an outline will appear. This outline defines the volume of space used to 
arrange the objects on the surface. Move the mouse until you are satisfied with the size of the filling volume.

Figure 7-18

Figure 7-17

Figure 7-16

• You can access the array settings dialog at any time by opening the “More actions” menu on the object 
toolbar and selecting “Array settings”. You can also press the Shift-F keyboard shortcut.

• Select the array you would like to modify.

• The parameters of the selected array will appear in the “Object array” dialog (Fig. 7-18) and can be 
adjusted as needed. 

The “Object Array” dialog will open automatically when creating an array.
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7.22  Placement and filling options

• Mode:
o  Even: The spacing between objects will remain the same, taking into account object sizes. 
o  Count: The spacing will be adjusted automatically to keep the number of objects constant.
o  Grid: The objects will be aligned on a regular grid, regardless of object size.

• The three columns represent the X, Y and Z axes respectively. The placement parameters, like alignment 
mode, spacing, or object count, can be modified independently for each axis.

o  Start: Defines the margin between the start of the filling volume and the first object.
o  End: Defines the margin between the last object and the end of the filling volume.
o  Spacing: The empty space inserted between two sucessive objects along the axis (Fig. 7-21b).
o  Random: Sets the amount of random variations applied onto the placement along the axis.
o  Size: Shows the dimensions of a single object in the volume (can not be modified).
o  Extend: The current size of the entire filling volume.
o  Count: The amount of objects inserted into the volume along the respective axis.

• Scale: will change the size of the individual objects within the array, without modifying the extends of the filling volume itself.

• Clicking on “Settings” will allow access to additional array options and features:
o  Allow automatic resizing: Enabling this options allows Store Visualizer to dynamically resize the filling volume extends if more space is 

needed.
o  Delete current array: Removes the currently selected array.
o  Break to objects: Allows access to the individual objects in the filling volume, by making them independent of the array.
o  Fit minimal extend: Refits the extends of the filling volume, so that it encompasses all objects without start or end margins.
o  Generate report: Generates a PDF placement report from the selected array (see chapter 17).

Figure 7-19

Figure 7-21a Figure 7-21b

• The “Object orientation” section controls how individual objects are oriented (rotated) within the array.The preset list contains 
a predefined selection of commonly used orientations. You may also customize the orientation manually through the Azimuth, 
Elevation and Heading fields (Fig. 7-20).

Figure 7-20
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o Random X,Y,Z o Random X,Y,Z
o Rotate 118°

Figure 7-24 Figure 7-25a Figure 7-25b

Randomizer settings:

7.23  Array randomizer

Sometimes, product sets created with an array will look too ‘perfect’ and aligned for a real world store scenario. 
Adding random perturbations into the process of positioning product onto shelves will improve the realistic 
aspect of the products. 

Use the randomizer feature to slightly vary the spacing and orientation of the individual objects within the 
array and to simulate the imperfections found in a real life store.  

Figure 7-22

Figure 7-23

o  Random X,Y,Z : Randomly displaces the objects along the respective axes (Fig. 7-22).
o  Rotate : Adds a random rotation to the objects in the array (Fig. 7-23).
o  Axis of rotation : Selects one or several axes to apply the rotation too.
o  Offset : Randomly moves layers of objects on top of each others.
o  Random snap : Randomly rotates the object by multiples of a fixed angle (eg. randomly rotate in steps of 

45 degrees) (Fig. 7-23).

o Random X,Y,Z
o Rotate 196°
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Chapter 8 : Anchor points and snapping

It can sometimes be difficult to precisely place an object against another one or attach two objects at a specific point. Hanging blister packs onto a hook 
is a typical example. The anchor function enables an easier placement of an object with an anchor point onto an anchor line. 

8.1  Introduction

8.2  Creating an anchor point

Figure 8-02

The center of the crosshair in 
the gizmo represents the exact 
position of the anchor point.

The entry currently selected in the list of anchor points is the default anchor. A model can have several anchors. Select another anchor 
from the list to make it the default.

• Select the model you would like to add an anchor point to. It will appear in the model browser.
• Click on the “Show or edit anchor points” icon. The “Edit anchor points” dialog will open (Fig. 8-01).
• Click on “New entry” to create a new anchor point. It appears in the model browser as a small blue box gizmo near the model. Click on 

the box and drag it to the desired location. 
• Use the “model side view” feature (Fig. 8-02) to help you position the anchor point.

Figure 8-01
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8.3  Creating an anchor line

Figure 8-04

• Select the model you would like to add an anchor line to. It will appear in the model browser.
• Click on the “Show or edit anchor lines” icon. The “Edit anchor lines” dialog will open (Fig. 8-03).
• Click on “New entry” to create a new anchor line. The line appears in the model browser with two small blue box gizmos at each end, 

near the model. Click on the end points and drag them to the desired location.
• Use the “model side view” feature (Fig. 8-04) to help you position the anchor line.

Figure 8-03

Anchors lines added to a model are not active by default. Their use as snapping lines can be enabled or disabled on the snap 
settings dialog (see chapter 8.5).
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8.4  Positioning an object with anchors

• Before proceeding, make sure that “Automatic tangential align” and “Restrict surfaces” are disabled, so to avoid being restricted during object 
positioning. You can find these options on the object control options sidebar rollout (see chapter 7.20).

• Enable anchor line snapping in the “snap settings” dialog (see chapter 8.5). This will activate the use of snapping lines as guides during object 
creation.

• Enable object creation mode. Click on the “anchor selector” button and check “Use anchor points”. The default anchor point for the selected 
model will now be used as the creation attach point. See chapter 8.2 if you wish to change the default anchor.

• In the above example, the t-shirt uses an anchor point and the hook an anchor line. When moving the mouse near the anchor line of the hook 
during creation, the anchor point on the t-shirt will snap onto the hook and will be guided along its anchor line.
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8.5  Magnetic snap settings

Object transformations like movement, rotation or scale can be snapped to an invisible grid, allowing for precise alignments:

When constantly enabling a snap by using the “Always enable” option, the functionality of the Alt key is reversed. It is then used to 
temporarily disable the snap while moving, rotation, or scaling.

o  Translation controls the snap feature on movement operations:
  Snap distance defines how much the object will move at each snap step (in cm).
  Always enable movement snap permanently enables the snap on movements.

o  Rotation controls the snap feature on rotation operations:
  Snap angle defines how much the object will turn at each snap step (in degrees).
  Always enable rotation snap permanently enables the snap on rotations.

o  Scaling controls the snap feature on scaling operations:
  Snap factor defines how much the object will grow or shrink at each scale step (in %).
  Always enable scaling snap permanently enables the snap on scaling operations.

• Open the “Object control options” panel, as described in chapter 7.20.

• Click on the “Magnetic snap settings” button. The dialog shown in Fig. 8-05 will appear.

Figure 8-05

Once configured as described, the snap is enabled by pressing the Alt key while you are moving, rotating 
or scaling your objects. 

o  Anchor line snapping:
  Enable on object creation activates the use of anchor lines as snapping guides when creating 

objects.
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Chapter 9 : Construction modes

Store Visualizer exposes three construction modes: product manipulation, shelf creation and store design. Each mode targets a specific process 
in the work flow of creating the layout and shelving of a retail space and filling it up with products.

9.1  Introduction

Figure 9-01

• Select the Object placement toolbar by clicking on the “Object control” icon (Fig. 7-01) located on the bottom panel bar.
• The object placement toolbar appears and is now active. 
• Click on the “Change manipulation mode” button and enable the desired construction mode (Fig. 9-01).

o 	 Product manipulation mode: This is the standard manipulation mode active when you start Store Visualizer. It focuses on the 
manipulation of products on shelves. You will use this mode to place and interact with products in your store and for physical 
simulation.

o 	 Shelf creation mode: This mode is mainly used to quickly modify the shelf configuration within existing units. You can quickly 
access individual shelves, move them and create new ones.

o 	 Store design mode: In this mode you may easily create and manipulate larger shelving units as a whole, creating aisles and doing 
larger scale manipulation of the store layout.

Construction modes relieve you from complex and unintuitive manipulation of the freezing and grouping features of Store 
Visualizer, by fully automating it.

The typical workflow in Store Visualizer would look as follows:

All these steps can be mixed and repeated as required. The following sections explain the steps in more detail.

1) Load a shelf library or import your own 3D shelves
2) For imported shelves, define shelf type and metrics of the individual parts
3) Design the basic store layout using the store design mode
4) Adjust shelving in the shelf creation mode
5) Place your products on the shelves
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9.2  Store design mode

• Enter Store design mode by pressing the button on the toolbar or by selecting a shelf frame model in the library and enabling creation 
mode.

You may now select and manipulate large shelving units as combined blocks. An optional snapping mode is available for quickly 
and accurately aligning units and creating aisles. When selecting a unit, all shelves and products positioned onto the shelves are 
automatically selected and will be moved along.

The snapping can be toggled with the “Snap frames to frames” option in the “More actions” menu.
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This mode allows the manipulation of individual shelves within a unit. A special shelf snap is available for extremely easy creation 
and positioning of shelves. Products placed on a shelf can be automatically moved with the shelf without additional selection.

9.3  Shelf mode

• Enter Shelf mode by pressing the button on the toolbar or by selecting a shelf model in the library and enabling creation mode.

The precise positioning of shelves within a frame is controlled by the shelf metrics.
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9.4  Product manipulation mode

• Enter Product manipulation mode by pressing the button on the toolbar or by selecting a standard model in the library and enabling 
creation mode.

Enabling this mode will automatically freeze all shelving, so to not interfere with your product interaction. It will also automatically 
re-enable physics, which were disabled during store and shelf construction.

• Once you are satisfied with the placement and configuration of your shelves, enter product manipulation mode. This is the standard mode 
allowing you to place and interact with products on shelves (see chapter 7). 
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9.5  How to build a complete store?

1. Store design mode
2. Create and manipulate your shelf frames
3. Create the layout of your store according 
to your floor plan. Create aisles, add displays 
and branding elements to your store

4. Shelf creation mode
5. Create and manipulate your shelf panels, 
hook racks, baskets, etc

6. Product manipulation mode
7. Create and manipulate your products
8. Fill up your aisles with products

In addition to the manipulation mode selector on the object placement toolbar, a quick mode switch and keyboard 
shortcuts are available. 

When in either shelf creation mode or in store design mode, a respective icon will appear on the top left corner of the 
screen. Clicking this icon will open a menu with quick access to the three construction modes.

This feature is particularly useful when working in fullscreen mode and with hidden user interface.

9.6  Quick mode switch

The keyboard shortcuts F2 to F4 can be used to switch construction modes.
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When a model is imported into Store Visualizer, it is considered a standard model / product by default. As such, it will be available in “product 
manipulation mode”. If the imported model represents a shelf, a component of a shelf or a component of the large scale store infrastructure, then it 
will have to be declared as such to make it available in the appropriate construction mode and to have the correct shaders applied.

9.7  Defining and adjusting shelf models

• Select the 3D model in your library.

• Click on the “Edit shelf metrics” button to choose / change the model type. The 
“Shelf metrics” dialog will open (Fig. 9-02).

• By default a 3D model imported into Store Visualizer will be a standard model. You 
will have to change the type if your model is not a product, so to make it available in 
other construction modes.

• Select shelf frame if your model is a shelf frame, a support, an individual backplate 
or any other shelving unit with a closed backpanel.

• Select shelf panel if your model is a shelf panel, a basket rack or similar.

• Select shelf hooks if your model represents a hook rack.

• Select structural component if your model will be a part of the store geometry (walls, 
doors, banners, etc). The lighting shader is adapted when this model type is selected, 
so to offer maximal visual quality for large scale elements.

• Once you have selected the model type, you may proceed to adjust its metrics.

Shelving models provided with Store Visualizer are preconfigured and do not 
require any further adjustments. If you import your own shelving models and 
need assistance in optimally adjusting the metrics for best quality, then we 
recommend contacting your reseller about available training options.

Figure 9-02

Figure 9-03
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9.8  Layout view

Click on the “layout view” button again or press ‘t’ to switch back to standard 3D view.

• Select the navigation toolbar by clicking on the “Navigation” icon (Fig. 1-01) located on the bottom panel bar.
• The navigation toolbar appears.

• Click the “Toggle layout view” icon to activate or deactivate the layout view.

o 	 Use the mouse wheel or the Page Down /Page Up 
keys to zoom in and zoom out. You can also move the 
“View height” slider to quickly position the view at a 
given height.

o 	 Press space to toggle “freelook mode”. While in 
freelook mode, move your mouse or press the arrow 
keys to move around.

o 	 Use the standard object manipulation tools of Store 
Visualizer to interact with the objects in your store.

Figure 9-04

When layout view is enabled, your current project will be presented from a top-down perspective (Fig. 9-04). This floor plan view mode is very useful 
when editing the layout of your store on a larger scale, such as creating aisles, defining areas or changing large structural store components. 
When layout mode is active, Store Visualizer will jump to store design mode by default. While this is the most commonly used mode for floor plan 
editing, you may use any desired construction mode while in layout view.
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9.9  Shelf positioning
The shelf positioning dialog allows access to all shelf related data in a unified way. You can use this dialog to precisely adjust the heights and distances 
of individual shelf panels and to view additional meta-data associated with the products positioned on each shelf.

• Select the Object placement toolbar by clicking on the “Object control” icon (Fig. 1-01) located on the bottom panel bar.
• The object placement toolbar appears and is now active. 

• Open the “More actions” menu and select “Edit panel positions”. The panel positioning dialog will appear (Fig. 9-05).
• When a shelf is selected in Shelf manipulation mode (see chapter 9.3), its associated positioning and meta data will automatically 

appear in the shelf positioning dialog.

Figure 9-05

o 	 The shelf column lists or shelves available in the current unit, 
including the bottom shelf.

o 	 The distance column shows the distance of the respective shelf 
panel to the one just below it. You can edit and modify this value 
by double clicking on it.

o 	 The height column shows the absolute ground height of the 
respective shelf panel. You can edit and modify this value by 
double clicking on it

Selecting a shelf entry in the list will automatically select it in 
the 3D environment. Double clicking on a product entry will 
select all products of the specified type on the shelf and will 
switch to product manipulation mode.

Shelf entries in the list can be opened by double clicking on them. 
Below each shelf entry the amount of products placed onto the shelf is 
listed, aggregated by type. Selecting a product or shelf entry will display 
additional meta data about the item.

o 	 Products: Total amount of products on the selected shelf entry.

o 	 Weight: Total weight of the selected product entry (see chapter 
14.6 about assigning model weights).

o 	 More meta information can be displayed depending on the installed 
plugin modules.
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• Click the “Edit reflection spheres and zones” icon to reveal or hide the gizmos (Fig. 9-06) representing the reflection points in your 
store. When creating a project, a default reflection point is placed in the centre of the scene. Use the object selection and manipulation 
tools (see chapter 7) to select and move this reflection point through the 3D virtual store. The environment visible in the reflection of the 
objects will depend on the position you will have chosen. If the reflection of the environment in the 3D models is not acceptable, move 
the point. The environment shown in reflective objects will change according to the position you chose. Repeat the process until you 
are satisfied with the results.

In a virtual 3D store, the environment seen in all reflective objects is gathered from a point called the reflection point. You can create and move the 
reflection points in the most suitable zones depending on the layout of your store. Placing the reflection point at the center of an important aisle is a 
common approach.

Be careful not to place the reflection point inside an object or a shelf, behind a wall or below the floor. This would result in 
abnormal or missing reflections !

The global intensity of the reflections can be adjusted in the lighting settings (see chapter 13.3).

• For performance reasons, the reflections you see in objects will not adapt to large changes of your store in realtime. Click on the 
“Refresh reflections” button to synchronize the reflections if you made significant modifications in your store. Note that reflections are 
automatically refreshed when a project is opened.

9.10.1  Default reflection point

• Select the Environment toolbar by clicking on the “Environment” icon (Fig. 1-01) located on the bottom panel bar.
• The Environment toolbar appears and is now active.

Figure 9-06

9.10  Reflection points and zones
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• Click the “Open reflection zone settings” icon to open the reflection zone control window (Fig. 9-07). A list showing the reflection points 
appears. The default reflection point appears at the top of the list. 

9.10.2  Setting several reflection points
To improve the realism in the reflective parts of the objects positioned in your 3D virtual store, you can create and set several reflection points. Each 
new reflection point will be assigned to a reflection zone. The reflection of the environment visible in the reflective parts of the objects will depend on 
the position of the reflection point and will only affect objects positioned in the reflection zone assigned to it. You can, for example, create a zone for 
each aisle. 

• Click the “Add new entry” icon to add a new reflection zone. A blue selection pointer appears (Fig. 7-16). Select a starting point by 
pressing the left mouse button. While keeping it pressed, move the mouse in the desired direction to reveal a blue outline. This outline 
defines the new reflection zone in which the new reflection point will be active. All the reflective parts of objects positioned in this new 
zone will reflect the environment surrounding the new reflection point.

Figure 9-07

Move the mouse until you are satisfied with the size of the zone. Release the left button of your mouse to complete the creation. The 
surface of the zone will be represented by a red rectangle (Fig. 9-08). You can access and modify the properties of each zone as well 
as the reflection points using the dialog “Reflection zone settings” (Fig. 9-07).

Figure 9-08

Figure 9-09

Use the object selection and manipulation tools (see chapter 7) to select and move a point or a reflection zone. At its edges, the 
reflection zone has gizmos in the shape of red squares. Click these squares to adjust the shape of the zone (Fig. 9-09).

We recommend that you create and manipulate the reflection points and zones using the “layout view” mode (see chapter 
9.8).
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• Resolution: this setting lets you choose the resolution used to calculate the reflections of a point. The greater the resolution of 
the reflection point, the higher the quality of the reflection. A greater reflection resolution will increase memory consumption. The 
consumption of the graphic memory used by the reflection is indicated at the bottom of the “Reflection zone settings” window (Fig. 
9-07).

The default resolution is determined in the Preferences > 3D settings > Effects > Object reflections > Resolution.

• Click the “Remove entry” icon to clear the reflection zone and its point. The default reflection point cannot be deleted.

The reflective parts of objects not in a specific reflection zone will reflect the environment of the default reflection point.
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Chapter 10 : Assemblies

Combinations of objects can be joined together into assemblies and stored in a library. This allows the storage and easy reuse of constructions involving 
multiple objects, groups and arrays.

10.1  Creating an assembly

Figure 10-01

Don’t forget to assign the front and top sides of a new assembly, in the same way as you do for newly imported models (see chapter 
7.7) !

Figure 10-02

Assemblies act as blueprints. They contain the instructions needed to build the object construct they represent, but they do not directly contain the 
models. Instead, they reference models in the same or in another external library. If these models are unavailable, then the assembly referencing them 
is considered broken and cannot be built. Loading an external library containing the referenced models will automatically repair all assemblies using 
them.

• Select the library you would like to add the new assembly to (in the library panel, see chapter 7).
• Select the objects you would like to combine into an assembly. In this example, a shelving unit with one shelf panel (Fig. 10-01).
• Right click to open the contextual menu and select Assembly > Create new assembly.
• The assembly will be created in the “Assemblies” section of the library you selected earlier (Fig. 10-02) and will appear in the model browser 

when selected.
• You can now create instances of this assembly using the normal object creation tool (see chapter 7.9). The object construct represented by 

the assembly will be recreated in your 3D environment. Once created, the new objects will be independent of the assembly they originated 
from.
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An existing assembly can be modified or updated with new content at any time.

10.2  Updating an assembly

Figure 10-03 Figure 10-04

• Select the assembly you would like to update in the library panel.
• Select the objects that will replace the contents of the selected assembly. In this example, the original assembly will now be updated by a 

shelving unit with multiple shelf panels (Fig. 10-03).
• Right click to open the contextual menu and select Assembly > Update assembly.
• The assembly will now contain the new object construct.
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Chapter 11 : Using the scenegraph

The scenegraph is a tool that regroups all interactive elements present in the current project. Its purpose is the organization of the structure and the 
relationship between project elements. The structure of the scenegraph will change according to the project type, spherical or virtual 3D.

•  Select the Scene tab on the sidebar and open the “scenegraph” rollout (Fig. 11-01).

11.1  Introduction

o  World: Contains all instances belonging to the external world.
o  Objects: Contains all objects placed into the spherical environment.
o  Helpers: Contains all helper gizmos.

o  Store: Contains all modifiable structural elements of the store.
o  Shelves: Contains all the shelving present in the store.
o  Products: Contains all the products placed onto shelves and into the store.
o  Helpers: Contains all helper gizmos.

•  Scenegraph of a spherical environment project:

•  Scenegraph of a virtual 3D store:
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11.2  Scene elements

o  The “array” icon represents an object array. Clicking on it will change the visibility: 
		   If the icon is blue (active) then the associated array is visible.
		   If the icon is gray (inactive) then the associated array is hidden.

Displays a list of all elements of the project and shows their hierarchical relationships. Individual elements can be selected by clicking on them with 
the left mouse button. Use the Ctrl key to select multiple elements.

Figure 11-01

o  The “object” icon represents a single object. Clicking on it will change its visibility: 
		   If the icon is blue (active) then the associated object is visible.
		   If the icon is gray (inactive) then the associated object is hidden.

o  The “group” icon represents an element group. Clicking on it will change the group visibility: 
		   If the icon is blue (active) then all elements of the group are visible.
		   If the icon is gray (inactive) then all elements of the group are hidden.

o  A group may be closed or open. The latter case is reflected by a changed group icon.

o  The “flag” icon represents the selection state of an item. Click on it to select or unselect the associated 
element:
		   If the icon is red (active) then the associated element is selected.
		   If the icon is gray (inactive) then the associated element is unselected.

o  Scenegraph control panel. For details, see chapter 11.4.

o  The search function filters the displayed entries in the scenegraph according to your search terms.

o  Frozen elements cannot be selected or manipulated. This state is indicated by a “Lock” icon and a 
grayed out name. (See chapter 11.6)

o  The Store section contains all structural elements (chapter 9-07). 
o  The Shelves section contains all Shelf frames and Shelf panels in the store.

All objects in the products section will automatically be grouped according to the shelf they 
are placed on. This grouping adapts automatically when moving a product from one shelf 
to another.

Store Visualizer will automatically group shelving units. It is not recommended to modify 
this grouping!

o  The Products section contains all Products in the store.
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o  The “filter entries” icon opens more options for filtering entries (see chapter 11.3).



11.4  Scenegraph control panel

The control panel is located below the scenegraph. It contains functions used to manipulate and restructure scenegraph elements.

o  Select none: Clears the current selection.

o  Select all: Selects all elements in the scenegraph.

o  Show or hide objects: See Fig. 11-02.

o  Freeze or unfreeze object: See Fig. 11-03.

o  Toggle group mode: Opens or closes a group.

o  Group selected objects: Creates a new group with the selected objects (see chapter 11.7).

o  Dissocate current group: Dissociate a group.

o  Explode group: Explode the hierarchy below a group.
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In addition to filtering scenegraph entries by name, the advanced filter options allow the entries to be filtered by various object related states. You can, 
for example, display only selected objects or only frozen ones.

11.3  Filter entries

• Select the type of advanced filter from the drop down to enable it.

• Changes of object states in your project will not automatically affect the currently displayed entries when an 
advanced filter is enabled. Press the “Refresh filter” icon to propagate any changes to the filtered entries.

	 As an example, the ‘selected objects’ filter will display all entries that are selected at the time you enable the 
filter. If you subsequently modify the selection, the entries shown in the scenegraph will not change. Pressing 
refresh will update the filter to the new selection.

• Uncheck the filter icon to disable an advanced filter.



11.5  Show or hide objects
The show or hide objects button regroups features to modify the visibility states of one or several elements in the scenegraph.

o  Show all: Unhides all hidden elements.
o  Show selected: Unhides only the currently selected elements.
o  Hide all: Hides all elements in the scenegraph.
o  Hide selected: Hides only the currently selected elements.

Figure 11-02

11.6  Freeze or unfreeze objects

By freezing an element all interactions with the object are temporarily disabled. An object should be frozen to avoid accidental manipulations such 
as movements or rotations while interacting with other objects nearby. 

o  Freeze marked: Freeze the currently marked scenegraph element.
o  Freeze selected: Freeze the currently selected elements.
o  Freeze unselected: Freeze all objects that are not currently selected.
o  Freeze all: Freeze all objects in the project.
o  Unfreeze marked: Unfreeze the currently marked scenegraph element.
o  Unfreeze all: Unfreeze all currently frozen objects.

Figure 11-03

Right clicking on an entry in the scenegraph will open a contextual menu offering an easy access to the most commonly used functions.
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Group selected objects

Dissociate current group

Select all objects you would like to group together:

The new group will appear in the scenegraph above its member elements. You can easily change its default name by using the name field 
on the top of the scenegraph area. 

A group of elements can be dissociated, rendering all member objects separate again. 

Removing a group will not remove any of its member objects ! It will only break the logical link between them. The dissociated member 
elements can be regrouped at any time.

11.7  Using groups

Elements that are logically or physically linked together can be placed into a group. Manipulations performed on the group will be applied to all 
contained member elements simultaneously. The relative distances between all group members are preserved. All object types are groupable. Groups 
can also be nested, creating subgroups. 

• Click on the  “Group selected objects ” icon located on the “scenegraph control” panel. The object context menu can also be used 
by right clicking on a selected object and choosing “Group selection”.

• Select the group to dissociate and press the “Dissociate current group ”. Again, this action can also be performed by using the context 
menu.

Explode current group
The explode group function can be used to completely dissociate all member elements and subgroups of a group at once, through the entire 
hierarchical branch.

Exploding a group will not remove any of its member objects except subgroups ! It will break the logical link between all elements in the 
group and all of its sub groups.

• Select the group to explode and click on the “Explode current group” icon. The same features is available through the context menu.
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The object context menu offers an easy and quick way to access several commonly used features.

11.8  Context menu

o  Move: Enables object movement mode.
o  Rotate: Enables rotation mode.
o  Scale: Change the object size.

o  Transform: Selects the axes affected by movement, rotation or scale operations.
o  Assembly: Create or update an assembly from the selection (see chapter 10).

o  Hide: Hide an object.
o  Freeze: Freeze an object.
o  Delete: Delete all selected objects.

o  Group selection: Group all selected objects.
o  Ungroup: Dissociate a group.
o  Explode: Dissociate the hierarchy below a group.
o  Open group: Open / close a group.

o  Hide selection: Hide all selected objects.
o  Freeze selection: Freeze all selected objects.

o  Model to library: Select the model of the object in the library.
o  Product viewer: Enable product view mode on the selected object (see chapter 15).

•   An object array offers additional options in its context menu (Fig. 11-05)

• Right click onto an object or a selection of objects to open the context menu: 

o  Break to objects : Allows access to the individual objects in the filling volume, by making them independent of    
the array.

o  Fit minimal extend : Refits the extends of the filling volume, so that it encompasses all objects without start or 
end margins.

Figure 11-04

Figure 11-05
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Chapter 12 :  Material editor

• On the sidebar, select the Scene tab, and open the “Material editor” panel. Fig. 12-01 will appear.
• Select a model from a library. A list of the materials making up the model will appear in the “Material editor”.

Only models that were initially imported with the “Modifiable Materials” option checked will allow access 
to their materials. See chapter 7.2 for more information about this option.

Store Visualizer allows you to easily modify the visual appearence of a 3D model. You can edit the surface color, assign artwork, change the reflectivity 
or select a different material for your model. The material editor regroups these options in a central location.

Figure 12-01

An OpenGL 2.0 compliant graphics card is required to view reflections and transparency. Please make 
sure that your graphics drivers are up to date if you do not see these effects.

o Material: The top section of the material editor panel lists all materials available in the currently selected model. 
Click to select the material entry you would like to modify. Double click on an entry to change the material name.

o 	Standard HDR: Standard HDR is the standard shader used by Store Visualizer for packaging models. Optional 
plugins may provide additional shaders.

o 	Copy: Copy the currently selected material to the clipboard.
o 	Paste:  Replace the currently selected material by the one in the clipboard.
o 	Presets: Open the material presets windows (see chapter 12.6).

o 	Surface appearance: This section describes the color and reflective properties of the material (see Chapter 
12.1).

o 	Emboss: This section allows embossing effects to be added to the surface (see chapter 12.2).

o 	Image viewer: Pressing one of the viewer buttons will display the image currently assigned to the respective 
layer.

o 	Modify image: These buttons will open the layer image modification window for the respective layer (see chapter 
12.5).

o 	Transparency: This section controls the transparency and translucency of the material (see chapter 12.3).

o 	Environment settings: Use the shadow intensity control to change the strength of the shadows generated by 
objects created from this model.

o 	Reflect: Uncheck “Reflect” if objects created from this model should not be visible in reflections (this can improve 
performance).

o 	Advanced settings: This section covers more specific and advanced material settings, see chapter 12.4.
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12.1  Surface appearance

This section allows you to specify the color and the reflective properties of the surface. These properties are vital in defining the visual appearance 
of a material. By simply changing the following settings, you can create a wide range of materials such as paperboard, plastics, metals, glass and 
much more.

The color layer will add a constant color or a color image to your models, like for example a label:

No color Color imageConstant color

The reflect field controls the overall surface reflectivity, ie. how reflective your model is. A low value will create a rough and dull surface material, such 
as paper. A medium value will simulate varnished or coated surfaces, as well as smooth materials like plastics. Very high values, up to 100%, will 
simulate mirror like reflections, such as from metals.

Reflect: 0 Reflect: 100%Reflect: 50% Reflectivity image
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The gloss field changes the glossiness of the reflection. A value of zero represents a very matte surface, while a value of 100 will make your model 
extremely shiny.

Gloss: 0 Gloss: 100%Gloss: 50% Glossiness image

Each of these layers (color, reflect and glossiness) can also be controlled by an image. Applying an image to the color layer will, for 
example, add a graphical artwork to your model. See chapter 12.5 for more details on layer images.

12.2  Embossing
You may add embossing or a relief to your model by using this section. The embossing mask is supplied as a grayscale layer image. The strength of 
the embossing can be controlled by changing the scale field. Both positive and negative embossing can be simulated. Use a negative scale value to 
flip the direction of the embossed areas (inwards becomes outwards and vice-versa).

No embossing Negative embossingPositive embossing
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12.3  Transparency

Opacity: 100% Opacity: 25%Opacity: 50% Opacity image

A model can be transparent, such as one made of glass or transparent plastic, or can have translucent parts. This section controls the opacity of the 
material (how much light is absorbed) and its color. An opacity value of zero will create an entirely transparent material, while it will be fully opaque 
at 100%.

Adding a transparency filter will create a material that tints anything seen through it (such as green bottle glass, for example). Two filter modes are 
available: color and layer. A color filter works with a single user supplied color, while a layer filter uses the color surface layer.

No filter Layer filterColor filter
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Store Visualizer supports a special transparency mode, available through the “clipping mask“ checkbox. When enabled, fully transparent parts of the 
opacity image will be entirely cut away from the rendered image. This mode is useful if the opacity image (or the alpha channel of the color image) 
contains a contour or shape mask rather than an actual transparency. A typical example is a shaped label.

o Without clipping mask: The transparent parts around the label are rendered as a fully transparent material. The label appears as if it was 
printed on a sheet of transparent plastic.

o 	With clipping mask: The transparent parts around the label are cut away. The label appears correctly.

Without clipping mask With clipping mask

Using clipping masks instead of normal transparency can improve rendering performance. It should always be used if the 
transparency layer of a material represents a mask or a clipping path. However clipping masks should never be used if the 
material contains semi-transparent areas or if actual transparency is needed.
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12.4  Advanced settings

This section gives access to advanced optical properties of the material, altering the way light interacts with it. These properties are required to make 
certain types of materials more realistic. Depending on the selected shader, this section may contain additional parameters.

o 	Secondary specular: Certain multi-layered materials, such as some metallic paints, use a second reflective 
layer below the main one, with different reflective properties and color. This typically results in a hazy and colored 
reflective halo surrounding the main sharp white reflection.

o 	Fresnel: Certain materials exhibit an optical phenomenon called the Fresnel effect. In these materials, the strength 
of the reflections changes with the viewing angle. A varnished wooden floor, for example, may only be moderately 
reflective when seen from above, but will almost turn into a mirror when viewed at a shallow angle. You can control 
the Fresnel effect by changing the value in the Fresnel spinner. At 100%, reflections are independent of viewing 
angle, and there will be no Fresnel effect. At 0%, the effect will be very visible through a strong dependency on 
viewing angle.

o 	 Falloff: The falloff effect simulates view dependent absorbency within transparent materials. The effect can be 
used to improve the visual realism of hollow objects made from a refractive transparent material (glass bottles, for 
example). When increasing the falloff value, the outline of a transparent object will look increasingly thick. A value 
of zero disables the effect.

o 	Metallic reflections: Metallic materials will tint their reflections while other type of materials will not. A gold bar, 
for example, will have gold colored reflections, while a blue plastic bottle will not have blue reflections. This option 
should be enabled if you are simulating a non-varnished metallic surface.

o 	Glossiness in reflect alpha: When enabled, the glossiness layer will be sourced from the alpha channel of the 
reflectivity layer image.  

o 	Opacity in color alpha: When enabled, the alpha channel of the color image layer will control the opacity of the 
material.

o 	Color correction: Use these settings to modify the hue and saturation of the base material.
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Figure 12-02

12.5  Layer images
Each of the aforementioned material layers (color, reflect, gloss, embossing and opacity) can be controled by an image. Press the edit image layer or 
the add image layer button next to the respective layer, as shown to the left. The image layer control window will appear (Fig. 12-02).

• Press the “Edit image layer” or the “Add image layer” button next to the respective layer.

o Enable: Checking this box will enable the respective image layer

o Image selector: Press the image selector button in order to load and apply an image to the layer.

o X/Y Move: Reposition the layer by moving it horizontally and vertically.
o X/Y Size: Change the horizontal and vertical dimensions of the layer.

Pressing the Ctrl key while operating the move or size spinners will increase their precision 
for fine tuning.

o Lock layer: When pressed, the position and size of this layer will automatically follow any modifications 
applied to the color layer.

o Channel: The UV mapping channel used by this layer. Store Visualizer supports up to 16 independent 
channels. By default the first available channel is used.

A small preview of the current image is shown on the right hand side of the image layer window. If you would like to see a larger preview, 
use the “Image viewer” buttons to the right of each layer entry in the material editor panel.
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Figure 12-03

Press the “Image selector” button to open the “Image loading” dialog. Store Visualizer supports all commonly used image formats such as jpeg, 
png, tiff, pdf and more.

o 	 Invert alpha channel: If this option is clicked then the system will invert the alpha channel of the loaded 
image.

o 	 Image tile: this setting defines how repeating images are handled.
  Automatic: Automatically select the most appropriate mode (this is the default).
  Repeat image: Repeat the image by tiling it.
  Clamp image: Clamp the image at the edges.

o 	Normal map: The selected image is treated as a XYZ normal map rather than as a height map (only 
available on embossing layer images).

o 	Logarithmic scale: Increase precision on embossing masks by using a logarithmic scale.

o 	Cut out label stencil: Enabling this option will add a transparent border around the image. This is useful 
if the image is a label. The border makes it easy to freely position the label on a product without affecting 
the other materials.

o 	Flip embossing in/out: Flips the direction of embossing masks. A positive displacement becomes 
negative, and vice-versa.
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12.6  Material presets

• Open the “Material editor” panel and press the “Material presets” button. Fig. 12-04 will appear. 

Materials can be independently stored by adding them to the material preset list. Material presets are automatically available from any environment 
and can be applied to models with a simple mouse click. Presets can store complete materials with all surface properties, duplicating the full original 
material. They can also store partial materials, only affecting specific layers or individual material settings.

o 	Default materials: Default materials contain a collection of generic standard materials.
o 	User materials: User materials contain your own custom presets.

o Create new preset: add a new preset using the material currently selected in the material editor (see 
chapter 12.7).

o 	Remove current present: permanently delete the selected preset or folder.
o 	Add folder: add a new empty folder to the custom material collection.
o Activate current preset: press this button to replace the material selected in the material editor by a 

preset.

Figure 12-04

Various commonly used standard materials already come with Store Visualizer. You can also add your own custom materials to the preset list.

Figure 12-05

12.7  Create new preset
When creating a new preset, you will have to define what parts of the current material are to be stored. By default everything is stored, and the preset 
represents a perfect replica of the original material. Some presets might only modify parts of an existing material. For example, a varnish will modify 
the reflectivity and glossiness of a material, but not its color or transparency. In such cases, you may freely choose the parts of the material that will 
be affected when the preset is activated.

o Enter a name for your new preset in the top entry field

o 	Select the settings and layer maps the preset applies to. By default, the new preset will apply to 
everything.

o 	Press OK to create the preset.

You cannot create or modify the presets in the “Default material” branch. Before creating a new 
material preset, make sure that either the “User materials” item or one of your own custom folders 
is selected.
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13.1  Tonemapping settings

• Click on the “Tonemapping settings” icon.
• The “Tonemapping system” dialog appears (Fig. 13-02).

Store Visualizer uses a high dynamic range rendering system (HDR). It is capable of simulating a much higher dynamic range of light than a typical 
computer screen or projector can display. In order to accommodate this, Store Visualizer uses an exposure system, much like a real camera does. 
Changing the exposure and tone mapping settings will adjust the way bright lights and high contrast areas are rendered. It will also define how colors 
are reproduced.

Figure 13-02

o  Exposure: Controls the overall brightness of the visualization.

o  Contrast: Increases or decreases the image contrast.

o  Tone mapping equation: Controls how light and colors are mapped to low dynamic range (typically 
Direct exposure or Logarithmic exposure should be used).

Chapter 13 : Environment panel

• Select the environment toolbar by clicking on the “Environment” icon (Fig. 1-01) located on the bottom panel bar.
• The environment toolbar appears (Fig. 13-01), and is now active.

Lighting settings are specific to the type of project currently loaded. Spherical photographic and virtual 3D projects each use a distinct lighting system. 
The lighting settings dialog will therefore look different depending on the type of project you currently work on.

• Exposure Panel: The exposure tab controls the way high dynamic range lights are rendered on a low 
dynamic range computer screen or projector.

Figure 13-01
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o  Enable glare: Check to enable the glare / bloom effect.

o  Intensity: Controls the strength of the effect.

o  Extra bright glare: Allows the effects of brightness / the bloom effect to be accentuated more.

o  The effect can optionally be attenuated over distance.

The “Logarithmic Exposure” tone mapping equation needs to be enabled in order to use glare (see chapter 13.1).

• Glare Panel: The glare settings can be used to add a glare or bloom effect around very bright light 
sources. This can often increase realism, as it simulates light intensities that cannot be reproduced on a 
normal computer screen or projector.

The tone mapping settings are pre-adjusted on projects that were created from templates or by using the store generation wizard.
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The spherical lighting is divided into three distinct parts. The ambient part represents the light an object receives from the environment when it is in 
shadow. By modifying it you can influence the way shadows are drawn, for example making them darker.
The diffuse part is the light directly received from intense light sources, for example overhead neon tubes, spot lights, etc. Changing the diffuse value 
will modify the brightness and intensity of the light striking the object. Finally, the reflective intensity defines how strong light is reflected in glossy 
objects. If your reflections tend to be too saturated in a bright environment, try to reduce this value. 

• Click on the “Environment light settings” icon. 
• The “Sphere lighting” window will appear (Fig. 13-03).

13.2  Spherical lighting

o 	Ambient shadows: Represents the light an object receives from the environment when it is in shadow.
o 	Direct light strenght: The light directly received from intense light sources, when the object is not in shadow.
o  Reflective intensity: The light reflections seen on glossy or shiny object surfaces.

Figure 13-03 The calibration settings page contains important information about the physical lighting characteristics 
of the spherical environment. These settings are created when the environment is generated and must 
be carefully balanced in order to obtain a physically plausible visual result. Under normal situations, these 
parameters should not be modified.

The intensity of each component can be adjusted in realtime by dragging the slider. Values are expressed as a 
percentage, and can also be direclty typed into the value field. The default value is zero, specifying no modification 
to the original calibrated intensity.

Spherical environments provided by VTales will already be calibrated for maximum realism. Typically you don’t need to change these settings. If you 
applied modifications to the lighting and you would like to return to the original default settings, then enter the value zero for all three components.
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13.3  3D environment lighting

• Click on the “Environment light settings” icon.
• The “Light settings” window will appear (Fig. 13-04).

The lighting in Virtual 3D environments works in a similar way to spherical lighting, as described in the previous chapter. The strength of ambient and 
diffuse light is however predetermined in virtual 3D stores and cannot be modified. Please adjust the exposure in the tone mapping settings (see 
chapter 13.1) if you wish to change the overall brightness of your store.

o 	Indirect shadow strength: Controls the general darkness of the shadows below shelves.

o 	Object shadow balance: The shadows affecting products placed on shelf can be made darker or lighter using this 
setting. The base shadow intensity is given by the “Indirect shadow strength” setting above.

o  Reflective intensity: This settings works the same way as in spherical lighting (see chapter 13.2).

o  Shelf bottom light strength: Represents the amount of ambient light reaching the bottom of a shelf panel. This 
is visible when viewing a shelf panel from below.

o Shadow smoothness: Controls the transition of shadows on a shelf. At 0 the shadow transition is very smooth with 
very low contrast, at 100 the transition is sharp with high contrast.

Figure 13-04

13.4  Stereo and multi-display control

• Click on the “Stereo and multi-display control” icon to enable or disable stereoscopic rendering.

Store Visualizer fully supports stereoscopic screens and projection systems on compatible hardware through an optional stereo plugin. Please contact 
your reseller for more information about stereo support in Store Visualizer. 

Stereoscopic settings: Preferences > Plugins > Stereo settings >Stereo rendering control. 
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Chapter 14 :  Physics

• Select the physics toolbar by clicking on the “Physics” icon (Fig. 1-01) located on the bottom panel bar.
• The physics toolbar appears (Fig. 14-01), and is now active.

• The Play/Stop button controls the current status of the simulation. Press “Play” to start running the simulation, and “Stop” to interrupt 
it. Once the simulation is running, all objects placed within the environment will be subject to physical laws. They will collide with other 
objects and will be affected by gravity and other external forces. Objects that were placed in an unstable position will slide, roll or fall.

14.1  Simulation control

Store Visualizer comes with a physical simulation module which allows you to simulate collisions and the application of physical forces onto your 
products. Amongst others, it can be used to interactively visualize shelf placement constraints or gravity feed shelving systems. Depending on the 
complexity of the projects, you will assign the physical simulation to the entire scene or to a selection of products.

Figure 14-01

When a project is opened, all the objects in it will be affected by the physical simulation. This is indicated by the message “Physics will affect the 
entire scene”. If you are working on a project with a very large number of products or your computer is not very powerful, you can assign the physical 
simulation to a specific part of the scene (see chapter 14.1.2).

14.1.1  Simulating physics on the entire scene

• When the physical simulation is running on part of the scene (see next chapter) and you want the entire scene to be affected, click the 
“Simulate the entire scene” icon. The current physical simulation process will stop automatically. Press the “Start” icon again to start 
the simulation.

By default, the physical simulation will always affect the entire scene.
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14.1.2 Simulating physics on part of the scene

• Step 1: Select the 3D objects to which you wish to apply the physical simulation. Then click the “Simulate all currently selected 
objects” icon. The message “Physics will affect parts of the scene” appears.

• Step 2: Press the “Start” icon to activate the simulation. The message “Physics is running on parts of the scene” appears. All 
products selected in step 1 will be affected by the physics. Press the “Stop” icon to interrupt the simulation.

You can assign the physical simulation to a specific part of the scene such as a display space, a shelf, a rack, a tray, a POS or similar (partial 
simulation). This can be desirable for the reasons mentioned in chapter 14.1.

To assign the physical simulation to all the products present on a shelf, on a rack or in a display space, you must first change 
construction mode (see chapter 9) to select the shelf, rack or display space to which you want to assign the simulation. Once you have 
selected it, click the “Simulate all currently selected objects” icon. Return to product mode (F2) to proceed to step 2.

A 3D object affected by a partial physical simulation will pass through all the other objects not affected by the partial 
simulation, except shelving, which will always be affected automatically.

All 3D objects created while the physical simulation is running on part of the scene will automatically be affected by the 
physics.

14.2  Put scene to sleep

• In certain situations some objects may become unstable and jitter or shake slightly. In order to stabilize such objects, select them and 
press the “Put scene to sleep” button.

A lot of physical instability issues are due to problems in the geometry of imported 3D models. Please use your CAD modeling 
application to make sure that your imported models have clean geometry and a planar base. The “Show collision envelope” 
tool in the Store Visualizer model browser can help you to identify such problems.
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14.3  Simulation time scale

• The Toggle between physics or conventional move button selects how collisions between the object and the environment are 
handled.

14.4.1  Toggle between physics or conventional move

You can interact (move/rotate) with objects under physical simulation the same way you learned in chapter 7. However when a simulation is running, 
a number of physical restrictions apply. You may not push an object through a shelf panel or another object, for example.

While you are moving or rotating an object, certain physical laws are temporarily disabled. This makes it easier to manipulate the object. Once you 
stop interacting with it, by releasing the left mouse button, all physical laws come back into effect. For example, you might move a product out of a 
shelf, holding it floating in the air. Once you release the mouse button, gravity will make it fall down.

14.4  Moving objects with the physics module
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The time scale slider controls the speed at which the simulation runs. By default, the simulation will run in realtime, corresponding 
to a scale of 1x. Dragging the slider to right will increase the speed of the simulation, creating a time lapse effect. Dragging it 
to the left will put the simulation into slow motion, allowing you to observe physical effects that would otherwise be too fast to 
see.

The object move, rotate or scale mode must be active in order to interact with objects. See chapter 7 for more information.

o If the icon is clicked, the displacement force of the object is reduced and proportional to its mass. The object collides with the 
other objects in its environment without unduly affecting them. This is the mode used by default.

o If the icon is not clicked, the displacement force of the object is very significant, ensuring its accurate movement. The objects 
located in the environment will be affected by it, giving priority to the moving object.



• Dragging is an alternative mode of moving an object. It is only available while a physical simulation is running. It works by grabbing the 
object at a point, and pulling it as if it was attached to a rubber band. Dragging is a very flexible mode of interaction, and it is the most 
physically correct. All physical properties are taken into account while dragging, including mass, momentum and friction.

•  Enable dragging mode by pressing the “Drag object” icon. Now click on the object you would like to move at the point you would like 
to attach the virtual rubber band. Hold the left mouse button and move the object.

• If you press the Ctrl key while still holding the left mouse button, you may move the object up and down. Without the Ctrl key pressed, 
your movements will be on a horizontal plane.

Drag object + CTRLDrag object

14.4.2  Drag object

104												                       Store Visualizer 14



14.5  Physical properties

• On the sidebar, select the Tools tab, and open the “Model physics” panel. Fig. 14-02 will appear.

The predefined material list contains a selection of commonly used generic material types. Click on an entry to 
assign a surface material to your model. Materials can be customized using the bounciness and friction spinners 
described below.

o 	Enable physics: Enable or disable physical simulation on objects created from the selected model.

Figure 14-02

In order to react realistically, the simulator needs to know about a number of physical properties, such as the models weight and surface.

Changing the surface material will only affect the way a model reacts in the physical simulation. It will not 
change its visual aspect.

o 	Bounciness: The bounciness or elasticity defines how easily an object bounces away on a collision. 0% will result 
in objects that do not bounce at all, while 100% will yield highly elastic objects.

o 	Material properties: Use the Material properties section to assign a certain surface material to your model. The 
surface type will change the way objects react when they are in contact with other surfaces or objects. A rough 
surface material such as cardboard is less likely to slide (it has higher friction) than a smooth plastic surface, for 
example.

o 	Mass: Defines the mass of the model in the weight unit active for the current project. Heavier objects will have 
more momentum when they collide with other objects, and they will require a larger force in order to be moved. The 
default mass is 1kg (2,2lb).
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o  Collision accuracy: See chapter 14.6 for details of the collision envelope parameters.

o 	Lock object position: Objects created from models with this option enabled will be glued to their position in 
the environment. They can still be moved by the user, but not by external forces such as those generated from 
collisions or by gravity. 

o 	Friction (CoF): Friction defines how fast a slipping object slows down. The higher this value, the more friction the 
object experiences while sliding over a surface and the quicker it will come to a halt.



14.6  Collision accuracy
The physics simulator typically uses an approximate shape representing the object so to increase the performance of the simulation. The collision 
accuracy section allows you to control the precision of this shape. The default accuracy, global envelope, is appropriate for most packaging models 
or consumer products. If however your model contains large cavities in which other objects are placed into (for example a tray or a display), then the 
default mode is not appropriate anymore. The shape would cover the cavities and you would not be able to place any objects into them. For such 
models, select the decomposed envelopes mode or the planar envelopes mode.

You can easily view the shapes generated by the physics simulator by using the two envelope viewer buttons in the model browser panel:

o Press the “Show model with collision envelope” button to display the model together with its physics envelope. Click the button 
again to hide the envelope.

Global box Global envelope

14.6.1  Viewing collision shapes

o Press “Show collision envelope” to display the physics envelope alone, without showing the original 3D model.

Global envelope

When an object is frozen in the scene, it will automatically have a highly accurate collision envelope.
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14.6.2  Collision envelope - Global box

• Global box: this mode approximates the objects’ shape with a box. This is a very high 
performance mode, and is ideally suited for models that have an inherently box-like 
shape. If applied to models that are not box-shaped, this mode may generate visual 
errors in the physical simulation.
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When a 3D model is imported, the physical module automatically detects 
whether it can have a box-type envelope. The global box collision envelope 
is automatically selected. You still have the option of choosing another type 
of envelope at any time.

The accuracy of collisions between the 3D models will depend on the collision envelope that you have allocated to each of your models. The physical 
simulation model offers you four types of collision envelope. You have to select the collision envelope suitable for the physical simulation to run 
optimally. 



14.6.3  Collision envelope - Global envelope

The global envelope mode is applied by default to new imported models with 
the exception of models that can have a box-type envelope (see previous 
chapter).

• Global envelope: this mode fits a convex skin around the model, following its outline 
as close as possible. The global envelope mode achieves both good performance and 
fits models with arbitrary shapes. 

	 As such, it is a good default choice for most non-box shaped products. This mode 
cannot be used with hollow models containing other objects (such as trays, hollow 
boxes or displays, for example). The envelope will cover the cavity and you will not be 
able to place objects inside it.
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When you select the decomposed envelopes mode or you modify the quality or the cavities, the system will have to prepare the new 
envelope. This operation is performed only once and the result of the calculation is saved in the library.

14.6.4  Collision envelope - Decomposed envelopes

o	 Quality: quality of the decomposed envelope.

Decomposed envelopes require high performance and may therefore significantly slow 
down the physical simulation if there are too many of them. We advise you to only activate 
this type of envelope if the envelopes above do not generate the required quality.

• Decomposed envelopes: this mode can fit a model very closely by using a combination 
of multiple convex envelopes and thus allows a very precise simulation. It should be 
used for models featuring large cavities.

o	 Concavities: Detail level for the decomposition of cavities.

Global envelope

In the example below, the object presents a global envelope versus a decomposed 
envelope. The global collision envelope is less accurate and the contours of the model 
are less well cut out but the simulation speed will be faster.
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Decomposed envelope - Coarse



14.6.5  Collision envelope - Planar envelopes

o	 Quality: Quality of the planar envelope. The further you drag the slider to the 
right, the higher the quality of the planar decomposition will be. In the example on 
the left, you can thus increase the rounded cut of the cardboard box.

• Planar envelopes are used in models consisting of hollows or individual planar 
elements, such as cardboard panels or metal sheets. Planar mode was specifically 
designed for use with trays, displays and similar models.

o	 Holes: Minimal area of holes to be decomposed. The further you drag the slider 
to the right, the more you decompose the holes present in your model. In example 
14-03, the holes on the bottom of the tray will appear with a higher decomposition 
of the holes.

Fig 14-03
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Planar mode does not work with models not made of distinct planar elements. In this 
case, the decomposed envelopes settings should be used instead.



Chapter 15 : Product viewer
The product viewer mode allows you to inspect the details of a product from all sides.

o  Reset orientation: Puts the object back into its original orientation it had on the shelf.
o  Center camera onto product: Center the product in the middle of the screen.
o  Change rotation pivot point: Modifies the rotation center of the object.
o  Second rotation axis is X: Performs a rotation around the Y and X axes.
o  Second rotation axis is Z: Performs a rotation around the Y and Z axes.
o  Open array control: Allows modifications of an object array while in product view mode.
o  Exit product viewer: Quits the viewer mode and returns the product back to the shelf (or press “p”).

When in product viewer mode, a control window will appear (Fig. 15-01):

The product viewer can be used on single objects, groups or arrays.

Figure 15-01

• Select the object to inspect by using the selection mode (see chapter 7).
• To enable the product view mode, you may either :

o   Click on the “Product viewer” button, located on the right hand side of the object manipulation toolbar. 
o   Or simply press the “p” key on your keyboard.

• The selected object(s) will leave the shelf and move towards the center of the aisle. It can then be closely inspected from all sides.
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You may also configure the movement trajectory by directly clicking on the curve graph.

The shelf to aisle movement can be performed on either the X axis, 
the Y axis or through automatic axis selection. It is recommended 
to let Store Visualizer choose the best axis automatically.

15.1  Product viewer settings

o  Viewer metrics:
 Distance: The distance the object will travel from its position on the shelf to the center of the 

aisle.
  Height: The height the object will float at when in product viewer mode.
  Steepness: Changes the angle of the curve the object will take when travelling to the center.
  Move time: The time the object takes to move from the shelf to the aisle (in seconds).

o  Camera follow:
  Enable camera follow: when clicked, the camera will automatically follow the object as it leaves 

or returns to the shelf.
  Reaction speed: adjusts the camera follow speed.

o  Toggle view: enters or quits the product viewer mode (you may also press the “p” key).
Figure 15-02

• Open the “More actions” menu located on the right hand side of the object manipulation toolbar.
• Select “Product viewer settings” or use the keyboard shortcut Shift+P. The settings dialog will appear (Fig. 15-02).
• You can now adjust the product viewer configuration for the current project.
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16.1  Snapshot
A snapshot of the current view can be taken at any time and saved to disk as a standard image file. Supported formats include JPEG, PNG, TIFF and 
others. 

• Choose a viewpoint at the place you would like to take the screenshot.
• Right click on the rendering area to open the context menu.
• Select File > Snapshot
• Select the location and enter the file name you would like to save the snapshot under and specify the image format. Click on Save.
• A dialog with the snapshot settings will appear (Fig. 16-01).

o  Resolution: Choose the resolution of your snapshot image (screen size, x2, x4, x8, custom). 
o  Quality: Additional anti-aliasing can be applied for best possible quality of your snapshot.
o  Width/Height: The image resolution the snapshot will be taken at. You can manually modify the resolution 

by choosing the “custom” setting in the resolution dropdown.

Figure 16-01

• Click OK to take the snapshot.

Chapter 16 : Snapshot and print

• The “quickshot” feature will take additional snapshots using the previously selected settings. The file names will be numbered automatically.
• Open the contextual menu and select File > Quick snapshot ...

16.2  Quick snapshot
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16.3  Print

• Choose a viewpoint at the place you would like to take the screenshot.

• Right click on the rendering area to open the context menu.

• Select File > Print.

• Store Visualizer will use your configured PDF viewer application to print the image.
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Chapter 17 : Create a placement report
When working with the “Object array” feature, Store Visualizer can create a placement report from your arrays. Report functionality is usually provided 
by customized plugins. This chapter describes the generic report process.

Step 1: Report header

You may freely configure the font size, type and color of the company and product name 
entries, such as they will be included in the report PDF.

Step 2: Image

In order to find a perfect camera view for the screenshot, just use the standard 
navigation features as described in chapter 2 and 3.

• Company name: type the name of your customer.
• Product name: the report title, or the name of the products shown in the report.
• Click the “Load an image” button to add logo images to the report:

o  Enable vendor logo: Includes your own logo on the top right of the report (your logo 
image can be set through the report plugin Preferences > Plugins).

o  Enable customer logo: Includes the client logo at the top left of the report.

• Select the array you would like to create a report from.
• Open the “More actions” menu located on the right hand side of the object manipulation toolbar and select “Array settings”. You can also 

press Shift-F, as described in chapter 21.
• Click on “Settings”, and select “Generate report” to launch the “Report wizard”:

• Click on the “Photo” icon to insert a screenshot of you current 3D view into the report.

• A preview of the screenshot appears. If you are not satisfied with the result, simply repeat the 
process with a different camera view.

Figure 17-01
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• Select the product you would like to show in the “Model browser”.
• Choose a “Layout”.
• Click on the layout element where a product should be added to, which will be shown with a red 

border.

• Click on “Add model browser image” to add the current model browser view.

Step 3: Product overview

You can switch the layout at any time. The inserted product views will be adjusted automatically.

• Different layouts are useful if you would like to show multiple views of the product or more than one product at the same time. It can also be 
used to show close-ups of distinct product parts.

• 	Select the layout element where the product 
should be placed by clicking on it. A red border 
will validate your selection.

• Pressing the “Add model browser image” 
button will add the model and view angle 
currently shown in the model browser to the 
selected layout element.
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• Comments about the project can be added into this field. They will appear on the report PDF. 

• This check box will “Include the generation date into report”.

• Author name: The name of the author who created the report (optional).

Step 4: Comments

The font style, size and alignment of your comment can be configured freely.

Step 5: PDF export

• PDF options:
o   Interpolate images: Increases image quality when the report PDF is zoomed onto.  
o   Show report after export: Opens the generated report with PDF reader after export.
o   Image quality: Choose the quality of the images included in the PDF. Higher quality will 

produce larger PDF files.

• Print the report directly without saving it first.

• Export the report as a standard PDF file.

Store Visualizer 14	 117



Step 6: The final generated report

The following elements make up your report:

• Company name: Your customer’s name.

• Product name: The name of the product shown on the report.

• Vendor logo: Your logo image.

• Customer logo: The logo image of your client.

• Screenshot of your product in the 3D environment.

•	Array placement: Placement metrics and surface area used by your 
products on shelf. The data is taken from the array that was used to the 
generate report.

• Layout: Views or close-ups of your product.

• Comments related to the project.

• Date the report was created.
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Chapter 18 : Create a standalone viewer
Sometimes you might want to share your projects with colleagues or clients that do not have Store Visualizer installed on their computer. While you 
could take screenshots or generate a report as described above, it is often more effective to let them explore the project the same way that you 
designed it in Store Visualizer - interactively and in real time.

With only a few mouse clicks, you can use Store Visualizer to generate a viewer file from your project. This small executable file can easily be copied, 
sent by email or put onto a website. By simply double clicking it, your clients will be able to view a realtime 360° representation of your project at the 
point you selected. 

• Right click on the Store Visualizer render area to open the main contextual menu.

•  Select File > Export.

Figure 18-01

On the following screen, you will be able to add information about your project that your client will see when 
running the viewer. Note that all fields are optional, and you may leave them blank.

o  Title: Name of the view exporter.
o  Author: Author of the view exporter.
o  Comment: Comment your view exporter.

o  Compression : The exported viewer file is compressed, so to keep it small and easy to send over 
the internet. This compression can sometimes impact the visual quality of your project when the 
client views it. You can choose the amount of compression under compression quality. The higher 
the quality the larger the resulting viewer file will be.

 
o  Target system: Select the system the viewer should be able to run on (Windows or Mac OS).

o  Overlay image: Add an overlay image on your viewer to personalize your project.

•  Click on export to generate the view exporter.

•  Enter the name of the viewer file you would like to export. The file type depends on your clients computer 
system. Windows viewers are executable files (.exe), Mac OS viewers are compressed application 
bundles (*.zip). You can create Windows viewers even if you are running on a Mac and vice-versa.

•  Click on Save. The “Spherical view exporter” dialog appears (Fig. 18-01).
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The system will generate a viewer file at your selected location. It can be run by simply double clicking it. The viewer will work on almost all computers 
and it requires no additional software to be installed prior to its use.

•  A short “usage information” screen appears. If you need more detailed information on how to use 
the viewer, please click the online help button.

•  After a click on start navigation, you will be viewing your project in real time.

The project can not be modified in any way from within the viewer.
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Chapter 19 : Creating and editing a video

19.1  Creating a new sequence

Store Visualizer has a module for creating and editing videos in real time. With this tool, you can produce video sequences for real-time presentations 
or create video files.

• Click the “Toggle movie timeline visibility” icon to display the video editor above your toolbar.

• Click the “Create a new sequence” icon to create the starting point of your new video sequence. Store Visualizer will automatically 
create an initial camera event and an initial scene event. These appear on the timeline (Fig.19-01) and are symbolised by a green 
(camera event) and blue (scene event) semi-circle. These are the starting points of your video.

Figure 19-01

A sequence is a continuation of events arranged on a timeline. Different types of events affect the path of the camera, the movement of objects or the 
control of the physics. The first step is to create a new sequence, to which you will then add the events. All the sequences you create will be stored 
in your project.

• The first camera event represents the current position of the real-time camera, i.e. the image currently visible in real time of your project. 
The position of the camera of the first camera event (see chapter 19.2.3) can be adjusted at a later stage.

• The first scene event represents all the 3D objects positioned in the scene when the sequence was created. For more information on 
scene events, please see chapter 19.4.1.

• Select the navigation toolbar by clicking on the “Navigation” icon (Fig. 1-01) located on the bottom panel bar.
• The navigation toolbar appears, and is now active.
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• Click the “Remove current sequence” icon if you want to delete the active sequence.

• The dropdown list of sequences (Fig. 19-02) lets you select the sequence that is currently active on the 
timeline. A project can contain multiple sequences.

Figure 19-02

19.1.1  Opening an existing sequence

• The input field also lets you rename your sequences.

19.1.2  Deleting an existing sequence

19.1.3  Activate or deactivate a track

Each track on the timeline can be individually activated or deactivated. The events present on a deactivated track will not be included in the reading 
or exporting of the sequence. Click on the respective icon to toggle the activation status of a track. All tracks are active by default.
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19.2  Creating a camera event

19.2.1  Adding a new camera event

A camera event is a camera point of view created from the position of the current view in real time. It appears on the track of camera events on the 
timeline and is represented by a green marker with an icon symbolising a camera. The continuity of camera events will define the path and speed of 
movement of the camera during the sequence.

Figure 19-03

• Use the classic navigation functions to move your camera to the point of view you want to add to the sequence. 

• Then click the “Add new camera event” icon situated at the front of the camera events track (Fig. 19-03). A new event corresponding 
to the current camera position will be added to the track (Fig. 19-04). 

Figure 19-04

• You can add a camera event at any point on the timeline. Click and move the cursor along the timeline (Fig. 19-05) to define the 
insertion point of the next camera event created by the “Add new camera event” function (Fig. 19-06).

Figure 19-05 Figure 19-06

Empty spaces between camera events represent periods of time during which the camera 
is not moving and is displaying its last position (Fig. 19-07).
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19.2.2  Manipulating and modifying camera events

Figure 19-07

• By default, a new event is created at the location of the cursor on the timeline. The length of the event corresponds to the time needed 
by the camera to move from the point of view of the previous camera event to the point of view of the event created (Fig. 19-07) 
depending on the navigation speed you are using at the time of creation (chapter 3.5).

• You can manipulate and modify events positioned on the timeline at any time. With your left mouse button, click the camera event 
to select it (Fig. 19-08), move your mouse from left to right while keeping the left button pressed to move the event on the timeline 
(Fig. 19-09). Press Delete to delete the selected event.

Figure 19-08 Figure 19-09

When you move or modify the length of an event, all subsequent events will be moved. The track of camera events is 
independent from the track of scene events. Only events on the affected track will move. 
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Figure 19-11

• The transition time between two camera points is not fixed and you can vary it by dragging one or other end of the event. 

The longer the camera event, the slower the movement of the camera, and vice versa.

• If you reduce the length of your camera event to the minimum, this will become an instant camera event (Fig. 19-11). The movement 
of the camera between the previous camera event and this camera event will thus be instant. 

• When you attach one camera event next to another, you create a continuity of movement between the positions of the two cameras (Fig. 
19-10). This will be translated into a continuous movement, without stopping, between the camera events when reading and exporting 
the sequence.

Figure 19-10
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• When you create a camera event, the speed of its movement will depend on the real-time navigation speed you use at the time of 
creation. The longer the camera event, the slower the movement of the camera, and vice versa. To avoid variations in speed between 
your various camera events, you can normalise the speed of the entire sequence or of several selected camera events.

19.2.4 Camera speed

19.2.3 Adjusting the camera

The adjusted camera event will retain the same length on the timeline. It is, however, likely 
that the new camera position will be further away or closer than the old one. You can therefore 
“Normalize speed” of your camera event (chapter 19.2.4) to avoid having variations in speed 
on the path.

Figure 19-12

• If you are not satisfied with the point of view of your camera event, you can correct it using the camera events contextual menu. Select 
the camera event you wish to adjust and click your right mouse button to open the “contextual menu”. Choose “Adjust camera”. 
The camera event turns red while the position of your camera is being adjusted (Fig. 19-12). The adjustment is made using classic real-
time navigation functions. When you have finished adjusting the camera, re-open the camera events contextual menu and click “Adjust 
camera” again. The camera event turns back to green and the new camera position is taken into account.

Figure 19-13

• Select the camera event you wish to adjust and click your right mouse button to open the “contextual 
menu”. Choose “Normalize speed”. The “Normalize camera speed” window opens (Fig. 19-13). Next, 
choose whether you wish to modify the speed of movement of the entire sequence or just one or more 
events. Select the desired speed of movement and click OK. The camera events will adjust on the 
timeline.

A panoramic movement in a camera event does not constitute a movement of the camera, 
but merely a rotation of it. The time to perform the rotation will always be one second by 
default. Store Visualizer will always choose the shortest route to perform the rotation. If you 
wish to modify the speed of rotation of the camera, simply adjust the length of the event on 
the timeline.

The first camera event, representing the point of view of your camera during the creation of the sequence, can also be 
adjusted in the same way as the other camera events!
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19.3  Viewing the sequence in real time

• The “Move cursor to the start/ to the end of the sequence” icons position the cursor at the beginning or end of the current 
video sequence. 

• The “Move cursor to the previous/to the next event” icons allow the cursor to be moved between the camera events of the 
current sequence. 

• To view the video, make sure the cursor is positioned at the point at which you want playback to start and click the “Start or stop real-
time playback” icon. The timeline turns red (Fig. 19-14) to inform you that the cursor is now active. Click the icon again to stop playback 
of the sequence.

Throughout the creation of your video sequence you can view the actions of your camera and scene events using the timeline’s playback controls. 
The cursor (Fig. 19-14) represents the insertion point of events or playback on the timeline. You can place the cursor at any point in the sequence. The 
cursor may be active or inactive. If it is inactive, the cursor serves to determine the insertion point at the creation of a new event (see chapter 19.2). 
If it is active, the cursor represents a playback head on the timeline. By moving it, you can freely view the results of your sequence.

• Click the “Activate cursor” icon to activate it. The timeline turns red. Next, move the cursor to view the video according to the location of 
the cursor. Re-click the icon to deactivate the cursor. All interactive manipulations in the project (for example: navigation of the camera, 
creation or movement of objects, etc.) will automatically deactivate the cursor.

During playback of the sequence, you can reposition the cursor along the timeline by 
clicking the desired location. Playback will not be interrupted.

Fade effects between scene events (see chapter 19.4.1) will not be visible when viewing in real time. The result will only be visible 
on the exported video.

Figure 19-14
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19.4  Creating an event on the scene track

19.4.1  Creating a scene event

• You can add a scene event at any point on the timeline. Click and move the cursor (Fig. 19-05) to mark the insertion point of your next 
scene event.

• Next click the “Add an event to the scene track” icon situated in front of the scene events track and select “Add new scene event” 
(Fig. 19-15). 

The scene track of the timeline brings together the three types of events linked to the manipulation of objects: the scene event, the physics event 
et the product viewer event. The first scene event, created automatically during the creation of the sequence, includes the positioning information 
for all the 3D objects placed in your project.

A scene event is a complete automated copy of the scenegraph. The scenegraph 
includes all the information relating to the 3D objects placed in the project.

A scene event represents all the modifications relating to 3D objects that you have made in your project since the previous scene event. The 
modifications taken into account by a scene event are the creation of new objects, the creation of multiple objects, the deletion of objects, the 
replacement of objects and the manipulation of objects (movement, rotation and change of scale).

Figure 19-15

• By default, when you create a scene event, it will be instant (Fig. 19-16). The modifications made by the event to the 3D objects present 
in your project will be instant.

Figure 19-16

For example, if the scene event represents the creation of an object, the 3D object will 
be created instantly. If the event represents the movement of an object, for example 
the movement of a product from one shelf to another, the object will appear instantly 
on the other shelf. You will not see the object moving from one shelf to the other.
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• You can modify the duration of a selected scene event by dragging the end of the scene event (Fig. 19-17). The scene event will no 
longer be instant, but progressive over the entire duration of the event. This will have an impact on the modifications represented by the 
scene event, such as the creation of new objects, the manipulation of objects, etc.

For example, if you have moved a 3D object from one shelf to another, you will see the object moving 
from one shelf to the other. The speed of movement will depend on the duration of the event. The 
creation or deletion of a 3D object will take place via a fade during the scene event.

Figure 19-17
Attention: you cannot view fades in real time. They will be created when the video is 
exported.

• If you have made changes to the objects in your project and you wish that these are taken into account in an existing scene event, you 
can update the event. Select the scene event you wish to update and click your right mouse button to open the “contextual menu”. 
Choose “Update scene event”.

The first scene event created, representing all the 3D objects positioned in the scene 
during the creation of the sequence, can also be updated in the same way as manually 
created scene events!
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19.4.2  Creating a physics event on the entire scene

• You can add a physics event at any point on the timeline. Click and move the cursor (Fig. 19-05) to mark the insertion point of your next 
physics event.

• Next, click the “Add an event to the scene track” icon situated in front of the scene events track and select “Add new physics event” 
(Fig.19-18). 

The physics event allows the physical simulation to be started during a defined period on the entire scene (by default) or on a selection of objects. 
See chapter 14 for further physics details.

Figure 19-18

The physical simulation linked to a physics event cannot be viewed by dragging the 
cursor along the timeline. You have to start real-time playback (chapter 19.3) to view the 
simulation.

Figure 19-20

• Drag the end of the physics event (Fig. 19-20) to modify its duration. The default duration of the physical simulation is 3 seconds. The 
physical simulation is stopped automatically at the end of the physics event.

After a physics event has been created (on the entire scene or on a partial selection), we 
recommend that you “Start real-time playback” (chapter 19.3) to view the result of the 
physical simulation. After playback, add a new instant scene event after the physics event 
(Fig. 19-19) to freeze the last position of the 3D objects affected by the physics. 
Failing this, there is a risk of random interactions when the next scene event is added.

Figure 19-19
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o If you have already created a physics event affecting the entire scene, this can be transformed into a partial physics event. 
Select the 3D objects to which you wish to apply the physical simulation. On the timeline, choose the physics event you wish to 
modify and click your right mouse button to open the “contextual menu” (Fig. 19-22). Choose “Assign partial simulation”. 
The physical simulation will then only be active on the previously selected objects.

19.4.3  Creating a physics event on part of the scene

• By default, the physics event will be active on the entire scene. If you are working on a project containing a large number of 3D objects, 
it may be preferable to simulate the physics on part of the scene.

o  Select the 3D objects to which you wish to apply the physical simulation. Next, click the “Add an event to the scene track” icon 
situated in front of the scene events track and select “Add new physics event”. A window will open (Fig. 19-21) to ask if you 
want to assign the physics to the selection or to the entire scene. Click Selection. The physical simulation of the event created 
will then only be activated on the objects selected during its creation.

Figure 19-21

Figure 19-22

If you choose Scene, the physics event will assign the simulation 
to the entire scene (see chapter 19.4.2).
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19.4.4  Creating a product viewer event

• You can add a product viewer event at any point on the timeline. Click and move the cursor (Fig 19-05) to mark the insertion point of 
your next viewer event.

• Next, click the “Add an event to the scene track” icon situated in front of the scene events track and select “Add new product viewer 
event” (Fig. 19-23). The product viewer event appears on the timeline (Fig. 19-24). The event is split into three parts. The duration of 
each part can be adjusted.

Attention: tracking cameras cannot be added if another camera event is already 
present above the viewer event. Remove or move the camera event to insert cameras 
to follow the product.

The product viewer event allows the “Product viewer” function (chapter 15) to be integrated into a video sequence. Like the real-time viewer, the 
event creates an animation in three parts of a product selected in advance. In the first part, the product will leave its original position and position 
itself at the point you have set. During the second part of the animation, the product will perform a configurable gyration. At the end of the event, it will 
return to its original position.

Figure 19-23

• Select the object you wish to animate.

Figure 19-24

• Store Visualizer allows you, if you wish, to automatically add cameras that will follow the product animated by a viewer event. Select 
the event and click your right mouse button to open “the contextual menu”. Choose “Add camera events to follow the product”. 
Two camera events will automatically be created on the camera track in parallel with the viewer event (Fig. 19-25). These cameras will 
automatically be calibrated to follow the animation created by the event.

Figure 19-25

• The settings of the animation, such as height, distance and gyration, can be modified in the event properties (chapter 19.5).
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19.5  Event properties
• Each event present on the timeline has properties and settings that can be modified at any time.

• Next, click the “Open event properties” icon situated next to the timecode. The “Event properties” window will open.

• Select the event the properties of which you wish to modify.

19.5.1  Properties of camera, scene and physics events

19.5.2  Properties of the viewer event

o  Event name: The name of the event.

o  Event length: Total duration of the event on the timeline, in seconds. 

o  Event name: The name of the event.

o  Event length: Total duration of the event on the timeline, in seconds.

o  Intro length: Duration of the first part of the event animation, when the object leaves its initial position.

o Extro length: Duration of the third part of the event animation, when the object returns to its initial 
position

o  Distance: Maximum distance reached in the direction of travel of the object during the animation.

o  Height: Maximum height achieved by the object during the animation.

o  Steepness: The incline of the displacement curve of the object during the animation.

o  Movement axis: Allows you to choose the axis along which the object moves during the animation (axis 
X, Y or automatic).

o  Gyration speed: Determines the speed of gyration in revolutions/second of the object during the second 
part of the animation.

o  Gyration angle: Determines the angle of gyration.

The physics event properties window will also specify whether the event in question affects part 
of the scene or the entire scene.
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19.6  Showing/hiding the path of the camera in the scene
The camera path defined by the events present on the camera track of the current sequence can be shown and manipulated graphically. The camera 
positions associated with the events are represented by blue squares (or red when a camera event is selected). These positions are connected by 
straight lines or curves. These represent the path taken by the camera during the playback or export of the video sequence. 

• Click the “Show/hide camera path in the scene” icon situated above the timeline. The path of the camera (blue line) as well as the 
position of the camera events (blue square) are displayed in the scene and can be modified. Click the icon again to deactivate the 
mode.

• The “Layout view” function (chapter 9.8) allows you to have a complete overview (Fig. 19-26) of your scene, of the position of your 
camera events and of the path taken by them. You can therefore easily identify camera tracks that risk crossing objects, shelves, etc.

Figure 19-26

o A straight line represents a camera event that ends with a 
delay before triggering the next camera event.

o A curve represents a succession of connected camera 
events.

o A gap between two points indicates that the next camera 
event is instant.

• You can freely move the positions of the cameras. Click the blue square symbolising a camera event (Fig. 19-26) and move it to the 
desired location. The movement will be in the horizontal plane. Press Ctrl during the movement to modify the height of the camera. The 
path taken by the camera will alter according to your changes. This may affect the speed of movement. It is recommended that you 
check the result of your modifications using the real-time playback of the sequence. 

The shape of the lines indicates the type of camera event:
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19.7  Exporting the video
• Click the “Export movie” icon situated above the timeline.

• Enter the name of the video file you wish to export. By default, the video will be encoded in H264.

• The “Movie export settings” window will appear (Fig. 19-27). Select the video encoding settings in the list of predefined options 
(chapter 19.7.1) and then click Proceed to export the video.

Figure 19-27

Figure 19-29
Figure 19-28

• When the video is exported, you can view your video immediately by clicking Play (Fig. 19-28). Store Visualizer will automatically open 
the video with your default multimedia player.

19.7.1  Predefined video encoding settings
Setting the video encoding is not always easy. We suggest that you choose from several predefined settings (Fig. 19-29) that refer to the use of the 
video:

o Quick preview: You wish to view the result of your video quickly, without being too concerned about the quality and size of the 
image.

o For the web (SD): You wish to broadcast your video on the web but do not want too high an image resolution (360p).

o For the web (HD): For broadcasting your video on the web in HD quality (720p).

o High quality presentation: Ideal for presentations. The video will have an HD image resolution (720p) and will use a higher 
antialiasing filter. 

o For broadcast or editing: Video of maximum quality and full HD resolution (1080p) for editing or for broadcasting on full HD media 
(1080p).

o Custom: For advanced uses, you can personalize the encoding settings. See chapter 19.7.2.
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The final quality of your video will depend on the video encoding settings. Attention: the higher the quality, the longer the export time 
and the greater the size of the video file. All this also depends on the total length of the video.

19.7.2  Video encoder and video settings

o Format: Lets you select a video encoder. The encoder selected by default is H264. The available 
formats depend on your operating system and the codecs you have installed. 

o Profile: Lets you choose the H264 profile used for encoding. This setting is only available on 
Windows.

o Quality: Determines the encoding quality of the video. A video of minimum quality will be more 
compressed (its file will be smaller) but will have significant graphic artefacts (image pixelation).

o Framerate: Represents the number of images displayed in one second.

o Image size: Proposes the standard image sizes. You can personalize the size if required.

o Antialiasing: An additional antialiasing filter can be applied to increase the quality of your video.

o Resolution: This is the size of the image in pixels.

If the encoding settings presented above do not suit the desired use, Store Visualizer lets you personalize all the video encoding settings.

Figure 19-30
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Chapter 20 : Preferences
To access the Preference pages, right click anywhere on the gray empty area (the 3D render area). The main contextual menu will appear. Select 
File > Preferences. The “Preferences” dialog window will appear.

20.1  System settings

o 	 Use native dialogs: Use the native windowing system of the host operating system 
for Store Visualizer dialogs.

• GUI settings (User interface settings)

o 	 Font: The font style used by the user interface.

o 	 Sidebar open by default: Open the sidebar when starting Store Visualizer.

o 	 Enable tool tips: Enable the display of help tooltips when hovering over UI items.

o 	 Double button contour: Draw buttons with a double outline.

o 	 Scheme: The user interface color theme.

• Language
o 	 Selects the user interface language.

• Welcome screen
o 	 Shows the welcome screen everytime Store Visualizer starts.
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• Display properties

o 	 Enable LOD system: Enable or disable the Level Of Detail rendering acceleration 
system. For more information about the LOD system, see chapter 7.8.

o 	 Enable screen cache: Enable internal screen render caching to increase 
responsiveness on complex scenes.

o 	 Fullscreen: Store Visualizer will start in fullscreen mode, removing all Windows UI 
elements.

o 	 Windowed: Store Visualizer will start in a window.

o 	 Antialiasing filter: The type and strength of the antialising filter used, to reduce 
jagged edges in the visualization. Antiliasing will significantly improve the quality of 
the rendering, but it will impact performance and increase memory usage.

• Fullscreen

o 	 Allow video mode switching: Allow Store Visualizer to switch to a different video 
mode and resolution than the one Windows is using.

o 	Enable transparent AA: Enable antialiasing on transparent or masked geometry.

o 	 Surface compression: Allow the use of compressed internal render surfaces, in 
order to reduce memory consumption.

o 	 Video mode list: List of available video modes and resolutions.

o 	 Colors: Video mode color depth (default: automatic).

o 	Refresh rate: Video mode refresh rate (default: automatic).
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o 	 Invert vertical mouse: Invert the vertical movement axis of the mouse for 
navigation.

• Navigation settings

o 	 Sensitivity: Sensitivity of the mouse movements.

o 	 Limit vertical angle: Limit the vertical viewing angle to the bottom - top range, 
avoiding over-turning of the navigation camera.

o 	Wire color: The color of the selection gizmo.
o 	Wire width: The width of the selection gizmo.

• Object selection

o 	 Default distance unit: The default distance unit used by Store Visualizer.
o 	 Default weight unit: The default weight unit used by Store Visualizer.

• Project settings

• Default report form
o 	 The report form used by default (only available when multiple report form plugins are 

loaded).

o 	 Default author: The default author assigned when creating new projects.
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20.2  Paths and directories

o Texture search paths: Search paths for texture files.
o Scene search paths: Search paths for 3dw scene files.

• Search paths: Search paths define the locations where Store Visualizer will search for 
resources when loading a project.

o Library search paths: Search paths for l3dw library files.

o HDR sphere search paths: Search paths for vtcep spherical environment files.

20.3  Graphics system information

• Graphics system information: This page displays information about your graphics card 
and the OpenGL driver.

140												                       Store Visualizer 14



20.4  Textures

Additional 3D: These pages contain highly specific settings controlling the visual. This data was automatically adjusted to your system 
when Store Visualizer was installed. Modifying these settings can very seriously degrade performance and lead to application failures or 
instability. Please do not modify these settings unless specifically instructed to do so by technical support.

o 	 Compress control maps: Allow the lossy compression of channel control maps, 
such as reflectivity, glossiness or opacity textures.

• General settings: The following settings trade memory usage and performance for 
quality:

o 	 Compress normal maps: Allow the lossy compression of normal maps.

o 	 Convert 16 bit maps to 8 bit: Convert 16 bit textures to 8 bit textures while loading 
(reduces memory usage).

• Filter: The filter type used for textures (default: best available). A high setting (anisotropic 
or better) is very important for good quality.

• Anisotropy: If using an anisotropic filter, this entry selects the quality of the anisotropy 
(higher quality settings can slightly reduce performance).

• Regular textures: Limit resolution and compression level of standard textures.

• High detail textures: Limit resolution and compression level of important and high priority 
textures (including those from high priority libraries).

• Static textures: Limit resolution and compression level of the textures from the static 
environment.

o 	 Load textures on demand: Allows Store Visualizer to load model textures when used. 
This settings will reduce memory consumption on large projects but may introduce 
small delays when clicking on a model in a library.
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Navigation 22
28

Add a new camera 33

Enable free look mode 28 Switch to previous camera 33

Orbit around target 29 Switch to next camera 33

Select orbit target point 29 Toggle movie timeline visibility 120

Height 30 Toggle layout view 30

Speed 31 More actions > Film and lens settings 36

More actions > Edit camera settings 34 More actions > Align camera to nearest axis 31

Chapter 21 : Icons and functions
21.1  Navigation panel
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Object control 38 Affect Z axis 56

Change manipulation mode 55
69

Change transform coordinate system 59

Select objects 55 Anchor: change transform pivot point 59

Create a new object 54 Replace model of all selected objects 60

Create an object array 62 Product viewer 110

Move selection 56 More actions > Delete 60

Rotate selection 56 More actions > Array settings 62

Scale selection 57 More actions > Panel positions 76

Auto select 58 More actions > Snap frames to frames 70

Affect X axis 56 More actions > Store layout view 75

Affect Y axis 56 More actions > Product viewer settings 111

21.2  Object panel
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21.3  Environment panel

Environment 77
97

Stereo and multi-display control 100

Environment type settings - Refresh reflections 77

Tonemapping settings 97 Edit reflection spheres and zones 77

Environment light settings 99 Open reflection zone settings 78

21.4  Physics panel

Physics 101 Put scene to sleep 102

Start simulation 101 Toggle between physics or conventional move 103

Stop simulation 101 Drag object by its pickup point 104

Simulate all currently selected objects 102 Show model with collision envelopes 106

Simulate the entire scene 101 Show collision envelopes 106
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21.5  Interface

Help 12 Graphic system information 139

Show information about the project 36 HDR mode is enabled -

Save project modifications 17 Graphics memory usage (%) -

21.6  Sidebar

System Open the “System” tab.

Tools Open the “Tools” tab.

Scene Open the “Scene” tab.
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21.7  File

Open project from list

Show preset information

Remove project from list

Clear entire project list

• In the system sidebar, select: System > File.

146												                       Store Visualizer 14



21.8  Command history

Undo entry

Redo entry

Goto history entry

Redo all inactive entries

Collapse all entries below current

Remove all entries above current

• In the system sidebar, select: System > Command history.
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21.9  Libraries

Models 39 Cut 39

Assemblies 80 Paste 39

Search entry 83 Create new folder 39

Library 39 Import model or resource 40

Important library 50 Import image 46

Copy 39 Delete from library 39

• In the system sidebar, select: Tools > Libraries.

148												                       Store Visualizer 14



Rotate model 51 Show collision envelopes 106

Pan model 51 Edit shelf metrics 74

Zoom model 51 Model complexicity 48

Center model 51 Select by current model 51

Model side views 51 Refresh the model and textures 51

Model view options 51 Show or edit anchor points 65

View or assign model sides 52 Show or edit anchor lines 66

Show model dimensions 51 Level of detail settings 53

Show model with collision envelopes 106 Reflective environment orientation 51

21.10  Model browser

• In the system sidebar, select: Tools > Model browser.
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Selection rectangle mode 61 Magnetic snap settings 68

Selection rectangle mode 61

21.11  Object control options

21.12  Scenegraph

• In the system sidebar, select: Tools > Object control.

• In the system sidebar, select: Scene > Scenegraph.

Search entries 83
84

Freeze or unfreeze objects 85

Filter entries 83
84

Group object 86

Refresh filter 84 Open group 86

Select none 84 Object array 89

Select all 84 Group selected objects 86

Selected object 83 Dissociate current group 86

Show / hide object 85 Explode current group 86
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21.13  Material editor

Copy material to clipboard 88 View (color/ reflectivity/ glossiness/ embossing/ 
opacity) image

94

Paste material from clipboard 88 Modify (color/ reflectivity/ glossiness/ embossing/ 
opacity) map

94

Open preset windows 88 Modify (color/ reflectivity/ glossiness/ embossing/ 
opacity) map

94

Create a new preset from current material 96 Activate selected preset 96

Remove selected preset 96 Default materials 96

Create a new folder 96 User materials 96

21.14  Material presets

• In the system sidebar, select: Scene > Material editor.

• In the system sidebar, select: Scene > Material editor > Open preset windows > Material presets.
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Chapter 22 : Shortcuts

F1 Help

F2 Product manipulation mode

F3 Shelf creation mode

F4 Store design mode

Space Enable free look mode

s Select objects

c Create a new object

f Create an object array

m Move selection

r Rotate selection

a Scale selection

e Replace model of all selected objects

p Product viewer
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v Orbit around target

x Affect X axis

y Affect Y axis

z Affect Z axis

t Layout view

o Model to library

Delete
or 

Ctrl+d

Remove all selected objects

Shift+F Array settings

Shift+P Product viewer settings

L Auto select

i Toggle fullscreen mode

b Toggle sidebar visibility

Shift 
+ m

Duplicate object + move

Shift 
+ r

Duplicate object + rotate
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Ctrl+i Import model or resource

Ctrl+o Open file

Ctrl+s Save

Ctrl+p Print

Ctrl+z Undo

Ctrl+y Redo

Ctrl+x Cut

Ctrl+c Copy

Ctrl+v Paste

Ctrl+f Freeze current selection

Ctrl+g Group current selection
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Shift 
+ m

Toggle between physics or conventional move
(Physics module)

Shift 
+ w

Toggle weak collisions
(Physics module)

d Drag object by its pickup point
(Physics module)

Shift+S Stereoscopic On/OFF

Alt+F4 Quit

Ctrl+Left Switch to previous camera

Ctrl+Right Switch to next camera

Store Visualizer 14	 155







Copyright © 2015 VTales graphics s.a.r.l. All Rights Reserved.
Store Visualizer User Guide.

This tutorial, as well as the software described in it, is furnished under license and may be used or copied only in accordance with the terms of such 
license. The content of this tutorial is furnished for informational use only, is subject to change without notice, and should not be construed as a 
commitment by VTales graphics s.a.r.l. VTales graphics s.a.r.l. assumes no responsibility or liability for any errors or inaccuracies that may appear in 
this documentation.

Except as permitted by such license, no part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any 
means, electronic, mechanical, recording, or otherwise, without the prior written permission of VTales graphics s.a.r.l.

Please remember that existing 3D objects, sounds, or images that you may want to include in your project may be protected under copyright law. The 
unauthorized incorporation of such material into your new work could be a violation of the rights of the copyright owner. Please be sure to obtain any 
permission required from the copyright owner.

Any references to company names in sample templates are for demonstration purposes only and are not intended to refer to any actual 
organization.

VTales and the VTales logo are either registered trademarks or trademarks of VTales graphics in Europe and/or other countries. All other trademarks 
are the property of their respective owners.

Written and designed at VTales graphics s.a.r.l., Pôle Phoenix B2 Route du Radôme - 22560 Pleumeur Bodou - FRANCE -

VTales graphics s.a.r.l
Pôle Phoenix B2

Route du Radôme
22560 Pleumeur-Bodou

France
Tel: +33/296/387974

http://www.vtales.com








	Chapter 1 : Interface
	Toolbar panel
	Contextual menu
	Sidebar
	1.1  The toolbar and information panel
	1.2  The sidebar
	1.3  Creating a new project
	1.4  Opening an existing project
	1.5  Closing a project
	1.6  Saving the project
	1.7  Quitting Store Visualizer

	Chapter 2 : Spherical photographic environments
	2.1  Introduction
	2.2  Creating a new spherical project from a template
	2.3  Navigating in a spherical photographic environment
	2.4  Navigation speed

	Chapter 3 : Virtual 3D environments
	3.1  Introduction
	3.2  Creating a new virtual 3D project from a template
	3.3  Create a new virtual store template
	3.4  Navigating through a full 3D environment
	3.4.1  The “FREE LOOK” mode
	3.4.2  The “WALKTHROUGH” mode
	3.4.3  Orbiting around a target
	3.4.4  Set camera height preset
	3.4.5  Toggle layout view
	3.4.6  Align camera to nearest axis

	3.5  Navigation speed

	Chapter 4 : Navigation options
	Chapter 5 : Using cameras
	5.1  Create new camera
	5.2  Camera list
	5.3  Next and previous camera
	5.4  Edit camera settings
	5.5  Camera path
	5.6  Film and lens settings

	Chapter 6 : Project settings
	6.1  Current project

	Chapter 7 : Product manipulation mode
	7.1  Using model libraries
	7.2  Importing an external object
	7.2.1  Model options
	7.2.2  Mapping options
	7.2.3  Settings
	7.2.4  Status

	7.3  Importing an external image
	7.3.1  Image options

	7.4  Organizing the model library
	7.5  Using external libraries
	7.5.1  Saving a project with modified libraries
	7.5.2  Settings for Library

	7.6  Using the model browser
	7.7  Assign model sides
	7.8  LOD system
	7.9  Placing an object
	7.10  Selecting the construction modes
	7.11  Selecting an object
	7.12  Moving a selection of objects
	7.13  Rotating a selection of objects
	7.14  Scaling a selection of objects
	7.15  Duplicating (cloning) a selection of objects
	7.16  Auto select
	7.17  Pivots and coordinate systems
	7.18  Replace model
	7.19  Removing a selection of objects
	7.20  Object control options
	7.21  Multiple object placement
	7.22  Placement and filling options
	7.23  Array randomizer

	Chapter 8 : Anchor points and snapping
	8.1  Introduction
	8.2  Creating an anchor point
	8.3  Creating an anchor line
	8.4  Positioning an object with anchors
	8.5  Magnetic snap settings

	Chapter 9 : Construction modes
	9.1  Introduction
	9.2  Store design mode
	9.3  Shelf mode
	9.4  Product manipulation mode
	9.5  How to build a complete store?
	9.6  Quick mode switch
	9.7  Defining and adjusting shelf models
	9.8  Layout view
	9.9  Shelf positioning
	9.10  Reflection points and zones
	9.10.1  Default reflection point
	9.10.2  Setting several reflection points


	Chapter 10 : Assemblies
	10.1  Creating an assembly
	10.2  Updating an assembly

	Chapter 11 : Using the scenegraph
	11.1  Introduction
	11.2  Scene elements
	11.3  Filter entries
	11.4  Scenegraph control panel
	11.5  Show or hide objects
	11.6  Freeze or unfreeze objects
	11.7  Using groups
	11.8  Context menu

	Chapter 12 :  Material editor
	12.1  Surface appearance
	12.2  Embossing
	12.3  Transparency
	12.4  Advanced settings
	12.5  Layer images
	12.5.1  Loading a new image

	12.6  Material presets
	12.7  Create new preset

	Chapter 13 : Environment panel
	13.1  Tonemapping settings
	13.2  Spherical lighting
	13.3  3D environment lighting
	13.4  Stereo and multi-display control

	Chapter 14 :  Physics
	14.1  Simulation control
	14.1.1  Simulating physics on the entire scene
	14.1.2 Simulating physics on part of the scene

	14.2  Put scene to sleep
	14.3  Simulation time scale
	14.4  Moving objects with the physics module
	14.4.1  Toggle between physics or conventional move
	14.4.2  Drag object

	14.5  Physical properties
	14.6  Collision accuracy
	14.6.1  Viewing collision shapes
	14.6.2  Collision envelope - Global box
	14.6.3  Collision envelope - Global envelope
	14.6.4  Collision envelope - Decomposed envelopes
	14.6.5  Collision envelope - Planar envelopes


	Chapter 15 : Product viewer
	15.1  Product viewer settings

	Chapter 16 : Snapshot and print
	16.1  Snapshot
	16.2  Quick snapshot
	16.3  Print

	Chapter 17 : Create a placement report
	Chapter 18 : Create a standalone viewer
	Chapter 19 : Creating and editing a video
	19.1  Creating a new sequence
	19.1.1  Opening an existing sequence
	19.1.2  Deleting an existing sequence
	19.1.3  Activate or deactivate a track

	19.2  Creating a camera event
	19.2.1  Adding a new camera event
	19.2.2  Manipulating and modifying camera events
	19.2.3 Adjusting the camera
	19.2.4 Camera speed

	19.3  Viewing the sequence in real time
	19.4  Creating an event on the scene track
	19.4.1  Creating a scene event
	19.4.2  Creating a physics event on the entire scene
	19.4.3  Creating a physics event on part of the scene
	19.4.4  Creating a product viewer event

	19.5  Event properties
	19.5.1  Properties of camera, scene and physics events
	19.5.2  Properties of the viewer event

	19.6  Showing/hiding the path of the camera in the scene
	19.7  Exporting the video
	19.7.1  Predefined video encoding settings
	19.7.2  Video encoder and video settings


	Chapter 20 : Preferences
	20.1  System settings
	20.2  Paths and directories
	20.3  Graphics system information
	20.4  Textures

	Chapter 21 : Icons and functions
	21.1  Navigation panel
	21.2  Object panel
	21.3  Environment panel
	21.4  Physics panel
	21.5  Interface
	21.6  Sidebar
	21.7  File
	21.8  Command history
	21.9  Libraries
	21.10  Model browser
	21.11  Object control options
	21.12  Scenegraph
	21.13  Material editor
	21.14  Material presets

	Chapter 22 : Shortcuts

